Audacity 2.0 Not Detecting Input from Echo Audiofire 4

I hope this is a simple problem to fix, but I have spent a few hours on the Wiki/Forums/Google and haven’t found a solution yet.

I am running Windows 7 SP1 64 bit with Audacity 2.0.0 that I installed with the .exe. I have been wanting to rip some cassette tapes for awhile and figured I’d use my Echo Audiofire 4 to do it. I had not used the Echo Audiofire 4 with Audacity on this new PC but had used it many times on my old PC with Windows XP and made several recordings so I was not expecting any problems.

Right now I have RCA to 1/4" converter cables I am using to connect the tape deck outputs to the 1/4" 3 and 4 inputs on the back of the Echo Audiofire 4. I have Windows setup to playback to my speaks and have confirmed I am able to play cassettes and reproduce the sound through the Echo Audiofire 4 and output to the speakers on my computer. No matter what I try I cannot seem to get Audacity to pick up the input. The correct devices/options are available for me to select but no sound makes it through to the software.

Echo Audiofire 4 for reference:

Note inputs 3 and 4 on the back where I am connected.

Here is the Echo Firewire Console that is showing the sound input:
Echo Firewire Console.jpg
Here is Audacity with the correct Input selected but NO sound input:
Audacity - New File.jpg
The device shows up correctly and displays input in Windows’ Sound Control Panel / Mixer
Sound CP - Recording.jpg
Post to be continued… (I can only add 3 attachments here…)

The device itself appears to be configured correctly on the recording tab:
And configured correctly in the Echo Firewire Console:
And finally I figured out where in Audacity to configure it and made sure it matched:
I installed Audacity yesterday and rebooted when I couldn’t get sound right away. After that I spent a good 2 hours reading the FAQ’s and setup instructions and still no dice. The input is there but it’s like it just doesn’t get anything from it even though I know Windows sees input from it.

Some people may suggest (and have suggested through other avenues of help requests…) that I use the, “Line In,” to my computer for this and that’s all well and good, but I need to get this interface working again anyway to record other things so this was my first test.

Thanks for your help/time. I am really hoping to get this working! I’d love to get these tapes ripped for some friends who have lost theirs.

So did you finally connect through line in and testing with this configuration?

Also I don’t know if this is of any help but you could check:

  1. It seems strange to me that Audacity shows speaker output to Realtek while Realtek shows not plugged in Windows audio properties?

  2. I see you use the stereo mix option in Windows audio properties, Audacity advices to uncheck the option under Preferences/Recording/Software Playthrough.

Hope it helps.

I don’t have RCA to 1/8" cable adapters so I haven’t tried testing that way yet. I also need to get this audio interface recording for other inputs/devices I will be recording so as I said, the cassette deck is the first test. The stereo mix option is disabled. I am not sure if that was clear in the screenshot. I just made sure to select show all there to make sure I wasn’t missing any inputs for the Echo Audiofire 4. The screenshot above is showing the recording tab, if you look at the playback tab the Realtek output shows up there no problem:

I have the exact same set up here and can only record from the two front inputs (1 & 2) unless I re-compile Audacity with ASIO support.

Are you able to select 4 channels here ?
Audacity cannot select which two inputs to use on a multi-channel interface. Audacity uses input 1 to N where N is the number of channels selected.
Seeing that you have “2 (Stereo) Input Channels” selected, Audacity will record from inputs 1 and 2. In order to record from inputs 3 and 4 you have to select “4 Input Channels” and record all four.