Audacity 2.0 Does Not Work on Windows XP Virtual Machine


I use Audacity on multiple computers to record with multiple microphones. One of these computers is running Windows 7 x64 and Audacity 2.0 works fine on it. I have Windows XP Virtual PC installed so I can run Audacity (2 instances of Audacity running on one machine essentially). I decided to upgrade to Audacity 2.0 on all of my computers and so far, the Windows XP Virtual Machine is the only one giving me troubles. It was previously running Audacity 1.2.6. I uninstalled this version of Audacity and attempted to install version 2.0 using both the executable file and the .zip file, but was presented the following message when attempting to launch the application: “Unable to execute file: C:Program FilesAudacityaudacity.exe CreateProcess failed; code 14001. This application has failed to start because the application configuration is incorrect. Reinstalling the application many fix this problem.” I have tried reinstalling the program, but the same error occurs. The specifications for the virtual machine are Windows XP SP3, 3.00GHz Processor, and 512MB RAM allocated to the virtual machine.

Help on this issue would be greatly appreciated.

Thank you.

I can visualize the other elves cringing at what you’re trying to do. Audacity has a hard enough time running on an unconditionally stable, single computer.

(2 instances of Audacity running on one machine essentially)

Were you able to get that to work on more than one machine? I would say that earlier machine was broken and what you have now is normal. We’ll see what the other elves say.


Audacity is quite capable of running on a virtual machine, even at the same time as running on the “real” operating system, provided that (a) the system is fast enough (b) the “real” system can support full duplex audio to the virtual machine at the same time as to the host system.
Whether or not this will work with a Windows host I’ve no idea, but it can certainly work with virtual XP on a Linux host.

See here:

See here:

Thank you, steve. This did the trick!