Audacity 2.0.5 hangs when reading oga file


Is Audacity supposed to be able to read .oga files? My version (2.0.5 from dmg, Mac OS 10.9.1) hangs indefinitely and has to be killed when trying to open this file:

Audacity should be able to play OGA files. OGA extension is interchangeable with OGG, though when you use File > Import > Audio and choose “Ogg Vorbis files”, OGA files are not seen, which we should fix by adding OGA as an expected extension.

VLC can play the problem file in question but it has information at the start of the file that Audacity does not understand:

…Role: audio/main…Name: audio_1…

which creates a endless loop.

Removing that information in a hex editor makes the Audacity OGG importer import the file, but then VLC does not understand the file.

Anyway, to open the file in Audacity, add the optional FFmpeg library to your computer as described here: .

Audacity still won’t import the file yet, because the OGG importer will try the file before FFmpeg does.

You should be able to rename the file to OGG then tell FFmpeg to import the file by using File > Import > Audio and choosing “FFmpeg-compatible files”, but there seems to be a bug here - the OGG importer takes the file anyway, so Audacity still freezes.

The solution is to create an “Extended Import” rule to make FFmpeg import the OGA file. To do this, choose Audacity > Preferences. Choose “Extended Import” on the left.

Click “Add new rule”. Type:


In the “Importer order” list, drag “FFmpeg-compatible files” to the top of the list.

Ensure “Attempt to use filter in OpenFile dialog first” is unchecked (not ticked). Click OK.

You should now be able to drag the problem file in, or use File > Open or File > Import > Audio using the “All files” filter.


This appears to be Bug 535 – Native Audacity formats won’t import via FFmpeg until click OK on Preferences except that there is some extra flakiness here that the bug happens at other times than new installation and it can take several OK’s on Preferences to “fix” it.


Wow, quick and detailed reply. Thanks a lot.