Audacity 2.0.5 crashing in Ubuntu Gnome 14.04

Hi everyone,

I’m regularly (as in 3 or 4 times an hour) having audacity crash on me. A little info on my setup:

AMD Phenom II X3 720 Processor
4Gb RAM (Geil fast RAM - 1600 maybe?)
Asus A5 something motherboard - using onboard sound card.
Nvidia Graphics card with the proprietary driver
Two HDDs - and I often use the non-OS HDD to store the .aup file
Standard Wireless Mic and Keyboard and a ShuttlePRO V2 (though this is new and it’s been doing this for ages)

Right, so it seems to happen most often when I’m hitting space to play or pause the audio track - I think it’s more common on Pause than on Play, but I haven’t nailed that down yet.

Audacity freezes, and after a minute or two, the ‘Force Quit’ dialogue pops up. No amount of waiting unfreezes Audacity (I’ve tried hours)

Once I reopen Audacity, a dialogue telling me that it’s recovered the file appears, but that there are orphan block files.

Can anyone help me with this?



Standard Wireless Mic

Standard as in “Standard Oil,” or Standard as in Plain and Ordinary?
How are the hard drives connected? Audacity doesn’t like Network Connected Drives very much.

Keep unplugging things and reducing the complexity of the machine until you can affect the problem. Not necessarily solve, but if you do something and the problem changes, that’s valuable, too.


Right, well the mouse is a logitech M185 - normal two buttons and a scroll wheel.
My HDDs are internally connected (SATA drive ports)

The only thing that I can think of that’s even slightly complex is that Audacity is running off HDD A, while autosaving, etc. on HDD B.

I’m pretty certain now that it’s only happening after it’s stopped play - once I’ve hit ‘space’ to stop it playing. Does it autosave at this point? Could that be tripping it up?

Are you sure the problem isn’t your Shuttle Pro v2 ? Try disconnecting that. I know that Shuttle Pro v2 used to have crashes on Windows and Mac when mapping its controls to SPACE and LEFT/RIGHT arrow then trying to “scrub” the audio.

If disconnecting Shuttle Pro does not help, the problem could be PulseAudio. Don’t lean down hard on the SPACE bar, and don’t press it rapidly. Or try choosing the (hw) devices in Device Toolbar instead of pulse.

SPACE starts or stops. It can be configured in Keyboard Preferences to pause instead but not to Start/Stop and Pause.

Playing and stopping does not modify the AUTOSAVE file.

The orphans are files for the Undo/Redo mechanism that Audacity could not delete because it did not exit cleanly.


Hi Gale,

This problem pre-dates the Shuttle Pro by 3 months - it started as soon as I installed latest versions of everything with the Ubuntu 14.04 upgrade (I did a clean new-system install, so I don’t think it can be an overwrite-install problem) . I’ve only had the shuttle pro for 3 days, so it can’t be that.

I am fond of the idea of it being the sound driver, because when stopping, Audacity has to tell the sound driver to halt - so if there’s a bug in there somewhere, that would explain the problem.

As for pulse, I don’t use that… I use either default, or my USB mic driver (it has a headphone socket as well, so it has a sound driver associated with it). At present, I’m only using the standard socket headphones, so I’m going to try unplugging the USB device for a while and see if the driver in that is upsetting ALSA/pulse, etc.

If it’s not that, I’ll try reassigning space to pause, and see if it’s that. I’ll let you know how I get on.



“Default” would also be pulse unless you have modified your system.


Well, I’ve been using Audacity for about 3 hours straight without a crash - which is a record since I installed it, so I think we can blame pulse. I switched to the HW sound option and since then all has been well. Nothing else has been removed or fiddled with, so I think that may be it solved.

Thanks for your help.


“Blame” is probably a bit harsh, though PulseAudio is certainly implicated :wink:
The Audacity developers are aware of this issue and are considering a number of ways that may resolve it. It appears to be due to an unusual combination of behaviours in Audacity, PortAudio (used by Audacity for connect to the sound system) and PulseAudio. Unfortunately it is a tricky problem to fix, but using the “hw” option (or using Jack Audio System) usually provides an effective workaround.