Audacity 2.0.4 does not launch on Windows XP

In reloading Audacity 2.0.4 I get

"An error occurred while trying to replace the existing file :
Delete file failed; Code 5.
Access is denied.

Click Retry to try again…"

I have uninstalled all versions of Audacity and updated Net but to no avail. What do I do now?


As your question does not directly relate to the topic where you posted it, I have separated into a new topic.

What do you mean “reloading”?
Are you trying to “re-install” or “update”?
Please describe in detail what you have done and what you are trying to do.

I had Audacity 2.0.3 and tried to replace it with the new version 2.0.4. I downloaded the new version and that failed. I uninstalled 2.0.3 to be told it was running. I cleared all Audacity programs from my PC. These included from C:program FilesAudacity and C:Documents and SettingsHP_OwnerMy DocumentsDownloads. I then downloaded Audacity 2.0.4 from Sourceforge and Google sites with the same error message.

I am running on Windows XP SP3.

Is there anything else you want to know?

Please tell us exactly what happens when you launch 2.0.4. “Failed” tells us nothing.

I assume that is why you saw the delete file error. You must quit a program to uninstall it, or to install new files over the top of it.

Please tell us exactly what that error message says. If it is still a “delete file” error, some files may be locked by Windows. You will need to reboot the computer, then try installing again.


Tried to delete all Audacity files but access denied to Audacity.exe and wxbase 28u_net_vc_custom.dll2.8.12.0 and wxmsu_adv_vc_custom.dll2.8.12.0 and wxmsu28u_core_vc_custom.dll2.8.12.0 and wxmsu28_html_vc_custom.dll2.8.12.0 files.
Download from new web site fails due to existing version running.

Any further thoughts?


As previously explained you have to quit Audacity before uninstalling it or reinstalling over it.

You can quit Audacity by task switching to it (hold ALT then press TAB) then when the Audacity window appears, choose File > Exit.

If you cannot see an Audacity window, open Windows Task Manager and quit audacity.exe on the Processes tab of Task Manager. See here for how to use Windows Task Manager

If Audacity asks to save changes at any time, save them (if you want to save them).

Otherwise simply click the Windows globe, then press the button to restart the computer. As long as you do not have Audacity in your start up group it will not be running and then you can reinstall it.


Tried it all but to no effect. I give up. I have cleared Audacity from all drives, but access is denied. On reload it confirms another Audacity is loaded and will go no further. Damn all computers and software.

Robert Dudgeon

My windows Task Manager does not show Audacity. I am not running Audacity. I have uninstalled Audacity. But it still can not download and run Audacity 2.0.4.

What else should a willing user do?

Robert Dudgeon

Unfortunately you won’t say what “reload” means. Windows can lock applications and installers so they cannot be closed or deleted. That’s why I keep suggesting you reboot. Have you done that yet?

To re-download Audacity you need to clear the download list in your web browser or download manager to make sure it does not keep giving you the same bad file.

You need to save the installer to your computer, not run the installer without saving it.

Does the installation complete but then you cannot see Audacity when you run it after installation?

If so, download the build in this topic . It’s not an installer so you don’t need to worry about installing anything. Just follow the instructions on that page.

If you get stuck, tell us exactly what goes wrong and write down any errors that you see in your reply.