Audacity 2.0.0 exporting problem, is there a bug? [SOLVED]

Hi to everyboby. This morning I downloaded and installed audacity 2.0.0 on snow leopard. I installed the lame for mp3 also.
I had exporting problems: either if I export in mp3 (yes I installed lame and I put the location of that in the prefereces of audacity) or wav, for instance.
The error he gave me it’s the impossibility to write the format: I checked on the web to solve it and there’re some solutions about the use of normal font and not safe symbol like "/- and so on… but the name of my file doesn’t contain strange symbol or strange font.
The original file was a .wav that I wanted to cut in a shorter version of that, converting in mp3
Is there a bug? Or am I an idiot in same way, usign this software? :smiley:
Thanks in advance

You you tell us the exact error message you receive and when you receive it?

– Bill

This happen when I’ve got a .wav file and:

  1. I click on “export”
  2. choose the extension of file (indipendently if I try to export in mp3 or wav), choose the destination and the file name and click save
  3. write or not (the eroor happens in both cases) the metadata and click ok
  4. after that the system says “it’s impossible to write on the destination file”. I translate the error because I’ve got the software in italian.
    What do you think?

Did you try to save and load from the same file? Open myMusic.wav and Export to myMusic.wav? Try just as an experiment Export to a different name. Using the same name like that is usually a bad idea,because if anything goes wrong, both the old and the new show get damaged.

Yes, punctuation marks in filenames cause trouble all the time and it’s the leading cause of that error. My/Music3/23/02.wav isn’t a filename. It’s one filename and three different folders. Try to Export one file to the desktop instead of My Music or other folder.

Have you ever run “Repair Permissions?”

Go > Utilities > Disk Utilities > select your hard drive (JimmyHD in my case) > Verify Disk and then Repair Permissions. Your permissions may have become scrambled so you don’t have permission to put the file where you want.


the intuition you had about my problem was correct! :smiley:
I verified the permissions in my hd: there were a lot of corrupted permissions and after repairing them, now I manage to export and save the file.
So we can considered the problem, solved!
Thank you to all of you for your efforts and suggestions!