Audacity 1.3.9b require specific version of automake?

Well, not audacity per se, but the libraries? In trying to compile the CVS version under Kubuntu Jaunty, I get configure errors from, e.g., libmad, complaining about an automake directive something about

AM_INIT_AUTOMAKE(-Wall foreign)

being unrecognized. The current Ubuntu level for automake seems to be 1.10.2 or something like that. Do the libraries require a different version? 1.11?


That’s what I’m using and it works.

For a lot of the dependencies you need to install the -dev packages.

Gloriosky, Sandy, that may have worked in some fashion not entirely clear at the moment.

I had somehow leaped to the conclusion that since libmad et al. was included in the audacity package from CVS, that would naturally include the needed development files. And maybe it does and my system was just confused. But when I went back and apt-get’d the libmad-dev package from the Ubuntu repositories and tried again, lo and also behold it not only finished the configuration sequence but also built and installed without collapsing and even loaded and Has Not Blown Up after a good ten minutes of running!

stevethefiddle is my newest hero.

Super :smiley:

By default Audacity will use your system libraries rather than the local ones (see ./configure --help ), but if your local libraries do not include the -dev packages then it fails.