audacity 1.3.8 // compilation error

hello

i am getting the following error when trying to compile audacity 1.3.8:

./configure: line 1883: syntax error near unexpected token taglib,1.4' ./configure: line 1883: AM_INIT_AUTOMAKE(taglib,1.4)’
configure: error: ./configure failed for lib-src/taglib

has anyone else run into this or know what i can do to get audacity to compile?

i am using ubuntu 8.04, lenovo T61 laptop. i’ve had no problems compiling audacity 1.3.7.

thanks for any help!

I’m no expert on this, but in the absence of any other suggestions, check which versions of libtag you have installed.
I’m on Ubuntu 9.04 and have the following:

libtag1c2a version 1.5-3
libtag1-dev version 1.5-3
libtagc0 version 1.5-3
libtagc0-dev version 1.5-3

Also I compile with these options:

./configure --prefix=/usr/ --program-suffix=-alpha

The prefix /usr/ makes Audacity install in the same directories that Ubuntu uses by default.

Adding the suffix “-alpha” means that I can have the latest greatest version of Audacity (built from the CVS source code) as well as the standard repo version (1.3.7). After running “make” and “sudo make install”, the new version of Audacity appears in the “Applications > Sound and Video” menu ad “Audacity alpha”.

The plug-ins folder will be in /usr/share/audacity-alpha/
It is probably a good idea to set the permissions of that folder so that you can write to it. This will enable you to easily add plug-ins for Audacity without needing to sudo.

Oh yes, another tip - when you have successfully run “make”, double click on the Audacity executable and check that it works OK before you bother installing it.

If you want to try out the cvs code (which I would recommend), open a Terminal window and use this command

cvs -d:pserver:anonymous@audacity.cvs.sourceforge.net:/cvsroot/audacity checkout audacity

This will download the latest code from cvs and put it in a folder called “audacity”. When it has finished downloading you can change to that folder with

cd audacity

and then run ./configure

hi and thanks very much for your reply.

i installed all the dependcies you recemmonded but now i get a whole new list or error messages when i run make:

src/hostapi/alsa/pa_linux_alsa.c:1372: error: ‘SND_PCM_TSTAMP_ENABLE’ undeclared (first use in this function)
src/hostapi/alsa/pa_linux_alsa.c:1372: error: (Each undeclared identifier is reported only once
src/hostapi/alsa/pa_linux_alsa.c:1372: error: for each function it appears in.)
make[2]: *** [src/hostapi/alsa/pa_linux_alsa.lo] Error 1
make[2]: Leaving directory /home/jason/Desktop/audacity-src-1.3.8/lib-src/portaudio-v19' make[1]: *** [portaudio-v19-recursive] Error 2 make[1]: Leaving directory /home/jason/Desktop/audacity-src-1.3.8/lib-src’
make: *** [audacity] Error 2
jason@jason-laptop:~/Desktop/audacity-src-1.3.8$

any idea what i should do now?

thanks again!

Well it’s getting there :slight_smile:

These are the ALSA packages that I have installed - they are not all required for Audacity - the last three packages are definitely not required.
screenshot.png
Also check if you have portaudio installed. You generally need to have the -dev files as well as the standard ones.

thanks again for your reply.

at this point, i’m wondering if i will be messing up my system adding these newer versions of alsa dependcies. i’m still on ubuntu 8.04, whereas you are using 9.04, which involves many other dependencies which other applications on my system still use.

for example: you have alsa-base 1.0.18, while i am still using 1.0.16

so, i’m wondering if why audacity doesn’t provide us with a more accurate list of dependcies for each update (as, for example, ardour does).

Change line 1372 in lib-src/portaudio-v19/src/hostapi/alsa/pa_linux_alsa.c from

SND_PCM_TSTAMP_ENABLE

to

SND_PCM_TSTAMP_MMAP.

ALSA docs say that SND_PCM_TSTAMP_MMAP is:
“Equivalent with SND_PCM_TSTAMP_ENABLE, just for compatibility with older
versions”

There is some information here:

I’m no expert on Linux compiling either, but in the case of the first error, the details did point to the problem. The command

sudo apt-get build-dep audacity

will often install what you need but on an outdated system may not give you all the latest versions of the libraries. Are you building from the minimal source tarball obtained from us?


Gale

hi gale

thanks for your reply.

well, i followed your suggestions but audacity now has the following error messages after i run make:

1478 translated messages, 20 fuzzy translations, 571 untranslated messages.
make[1]: Leaving directory `/home/jason/Desktop/audacity-src-1.3.8/locale’

gzipping the file this way prevents audacity.1 from getting deleted

cat help/audacity.1 | gzip -9 > help/audacity.1.gz
jason@jason-laptop:~/Desktop/audacity-src-1.3.8$

incidentally, i’ve been using audacity for three years now and this is the first time i’ve had this much trouble getting a new version installed.

i’m not sure what to do now. guess i will just stay with version 1.3.7.

it’s hard for me to believe, though, that no one else out there is having these problems compiling 1.3.8 on linux from the source tarball.

jason

I don’t know the purpose of making a gzip of audacity.1, however if that is the only error you receive you can ignore it and just do

./audacity &

after make to verify the program works.


Gale

thanks again for taking the time to help with these problems. i appreciate it.

well, i ran ./audacity & after make and the program seemed to be working ok.

just to make sure, though, i went from scratch again with ./configure > make…and strangely enough, after make this time i had no error messages. somehow, running ./audacity & had some effect on the whole process. a very weird problem as, like i said before, i’ve never had any difficulties like this getting new versions installed.

now the program is installed on my computer and it works.

jason

If you just do make again on an unchanged configure there won’t be anything to do, so no error. After ./configure, you should be able to just do:

sudo make install

(if you aren’t already) so avoid the two separate make and make install steps.


Gale

I’m getting the same error message as in the first post, compiling 1.3.9 on Puppy Linux. I actually got a different message initially, about aclocal-10, so I tried creating aclocal-10 as a link to my aclocal-9, which got me to this error message.
Since it sounds like installing or updating an external taglib was part of the solution for you, do you know whether you actually did have an external taglib to start with, or was it trying to compile an internal taglib?

It seems rather unusual to require aclocal-10 to compile something…

I also saw this person having the same problem:
http://ubuntuforums.org/showthread.php?p=7900278#post7900278

If you are registered on that forum you could refer him to the advice given by Gale Andrews in this thread. (it worked for jaskah )

I’m not - if I had a real answer I might sign up just to help him out. But I’m not sure that I do - I’d still like to know whether these guys having problems on Ubuntu have an external taglib to start with. I don’t have one, so I can’t help suspecting audacity has a problem now with building the internal taglib. Last time I built it (a couple of versions ago), it built just fine. If this is a problem, by helping people work around it we’ll just conceal it instead of helping it get fixed.

TagLib is used in Audacity for metadata support.

There are two different tarballs available. The standard source tarball (6.4 MB) assumes your system has the necessary dependencies (libraries) installed and that they are sufficiently up to date.

The full tarball (17.4 MB) is suggested for Windows and Mac machines which may lack the necessary dependencies to compile Audacity, though I assume it could also help resolve missing dependency problems for Linux as well. I don’t think it would automatically resolve problems with dependencies that are out of date on the system as compiling will often use system libraries in preference to local libraries.

Taglib is included in the standard source tarball - I think it’s version 1.5
The original poster was using taglib 1.4
The version included in Dapper and Hardy is 1.4
The version of taglib included in Jaunty (also Intrepid and Karmic) is 1.5
Audacity works with taglib 1.5 (that’s the version that I’ve got on Jaunty) - I’m no expert on this, but it looks to me like taglib 1.4 is too old.

When the original poster updated taglib from 1.4 to 1.5, that particular problem was resolved.

hello

i grabbed the most current version of audacity from this address in my terminal:

cvs -d:pserver:anonymous@audacity.cvs.sourceforge.net:/cvsroot/audacity checkout audacity

i then did the following in the unpacked audacity directory which i’d just downloaded:

Change line 1372 in lib-src/portaudio-v19/src/hostapi/alsa/pa_linux_alsa.c from

SND_PCM_TSTAMP_ENABLE

to

SND_PCM_TSTAMP_MMAP.

after i ran:
./configure
make
and, before installing, ./audacity & to make sure the program worked.

i still had some error messages after make but when i checked with ./audacity & everything seemed fine.

i am on ubuntu 8.04 and am currently using audacity v. 1.3.10-alpha-Sep 6 2009

i hope this helps.

I don’t think those last messages are really “errors”, just information that you and I don’t understand. Anyhow, I get those messages every time, but it doesn’t cause any problem.