Aud 3.2.1 64bit Win10 64bit Drag & drop files not working

before I begin:
When I drop files into Winamp 5.666+ the files play fine after dragging and dropping. Single file, or multiple.

It is only Audacity that givesd me this error of just giving me the cirlce with the crossbar, thereby blocking my file drops.
As though it does not recognise what the files are.
I’ve tried Flaac, mp3, wav. All give same result.

The files work perfectly correctly in my music DAWs, and all my media players (currently Winamp, Traktor 2, and ableton on windows 10, and JetAudio on Android. The files are fine.
All my configurations on windows are fine (they have to be to use DAW’s well on windows).

Also, when I try to use ‘import’ and go into relevant folders, Audacity doesn;t see ANYTHING. As though the files do not exist.
For all the difference it makes. Audacity was installed via right click ‘run as admin’.

I’ve got a lot of work to do tonight, and this has now put me back four hours. (Audacity is, or certainly was, my favorate tempo changer when in a hurry making a demo. But is un-useable at the moment in this respect.)

I found a cure for this I think:
After scratching my head for a few moments, I looked again at edit>preferences, even though I’ve never had to ‘‘set up’’ Audacity very much beyond installing it, or pointing it to my relevant audio drivers, had a look at the '‘allowed’ file extension list. Their appeared to be nothing in the list!
So I remembered FFmpg.
So tried re-installing a copy, and on re-opening Audacity, every went well. I can now drop files into Audacity once again.
For current FFmpeg go here>