Auacity won't record my microphone only my speakers?! Help!

Alright so, right now I’m trying to record just me talking for a school video project and Audacity refuses to record through my microphone. I really need to finish this project by next week. I am using a Blue Eyeball Microphone, I’m just trying to record through my mic. I have tried everything suggested on google but nothing works. Right now this is what my sound settings look like;

But the problem is that it doesn’t wanna record when the “Blue Eyeball 2.0” is set as the default device. It only wants to record when “Stereo Mix” is set as the default device. I’ve used Audacity before for a project back in March-ish but now it doesn’t want to work.
This is quiet frustrating since it use to work and now it doesn’t. I keep getting this error.
I need help. :frowning:

I’ll add my Audio Device Info if needed, just it’s really really REALLY long.

Right click on the USB microphone in the Windows Sound > Recording settings and select “Properties”.
Check that the sample rate and channels are set to 44100 Hz mono.

Yeah, they are. It’s still giving me the same error.

I would get rid of that “apowersoft” device. It’s messed up other users here. If your Realtek stereo mix is working, do you need “apowersoft”?


No I don’t think I need them. How would I go about removing them? Or do I just disable them?

You could simply right-click over all the apowersoft devices in Windows “Sound” to disable them, restart Audacity and see if it helped.

Or if you want to uninstall it go to the Windows Control Panel > Programs and Features, and look for apowersoft programs to uninstall (there could be more than one program). If you are not sure, ask here: .