Assertion error encoding WMA

I run Audacity on Windows 7(Simplified Chinese Edition), tonight I recorded an online radio program with Audacity, then I tried to export the recording into the form of WMA format (24kbps). I did this yesterday and the day before yesterday, Audacity did a good job, but it didn’t work well tonight, I’ve taken a snapshot of the warning pop-up window (in the attachment). Do you know what the problem is? The three Chinese words have been translated into English.
Audacity Error.png

Are you a user or a developer?

If only a user, please use Audacity 2.0.5 release from here: .

You should only see assertion errors in debug versions of Audacity.

Are you using FFmpeg from here: ?


I’m just an user, I know nothing about computer programing. I use FFmpeg in my Audacity and this FFmpeg Library comes from _

Where does your Audacity program come from?
The official download location is here:
The recommended version is the first link on that page:

Recommended Downloads - Latest Version of Audacity

  • Audacity 2.0.5 installer (.exe file, 21.2 MB, including help files) for Windows 2000/XP/Vista/Windows 7/Windows 8

I downloaded my Audacity 2.0.5 from _ and the FFmpeg Library used in my Audacity also came from the official user guide (as showed above).
About Audacity.png

Are you running Audacity from within Visual Studio? There is no need to do that. Just double-click “audacity.exe” to launch Audacity.

Restart Audacity. Post the contents of Help > Show Log… .

Does Audacity crash or the export fail when you see the assertion error?

Is there something different between the audio that you could export as WMA and the audio that you can’t export?

Has changing the WMA Export Options to 24 kbps created this problem?

Have you installed other applications just before this problem happened?


Has changing the WMA Export Options to 24 kbps created this problem?

Yes!!! You are right! I tried 32kbps and 64kbps WMA Export and the error had gone. Thank you very much.

Other format, mp3/ogg/m4a are available, only exporting to 24kbps WMA is abnormal.

I’ve tried 24 kbps WMA export in release and debug builds of our latest code, and don’t receive that error.

The error you note has been reported in 1.x builds of FFmpeg, but Audacity cannot use FFmpeg 1.x assuming you are choosing “WMA Files” when you export.