Applying effects to long files (approx 30 minutes or more) fails


I’m running Audacity 3.4.2 64-bit on Windows 10.

Best illustrated by example:

  • My goal is to upmix a stereo source to 5.1
  • I import a stereo file and use ‘duplicate’ to create the necessary tracks.
  • I select the first track (which will be the FL + FR channels in the 5.1 mix) and attempt to apply the “Remove Center” effect to it.
  • It runs for while, freezes, then the progress dialog disappears. No error message is issued. At this point, it’s as if I never attempted to apply the effect.

This happens only for long files. What do I mean by “long”?

  • I’ve successfully applied effects to 5 minute files, 10 minute files, etc., all the way up to 25 minute files.
  • I next chose a 40 minute file. That failed, as did 52 minute and 120 minute files.
  • Accordingly, it’s not something unique to the 40 minute file I tried first. Somewhere between 25 minutes (success) and 40 minutes (failure) is the limit, presumably based on my PC’s hardware: 8gb RAM and an AMD A4-5300 APU with Radeon™ HD Graphics 3.40 GHz processor.

I’m using the hard drive on my PC, by the way, not an external drive, USB drive, cloud storage, etc., so that’s not the problem. It’s a 1gb drive and has about 300gb free, so there’s plenty of storage for paging.

In all failure instances, the process ran for about 10 minutes. Obviously, the progress bar got closer to the end for the 40 minute file than for the 52 minute or 120 minute files.

I went to Edit > Preferences, but nothing jumped out at me to change. I did try adding a zero to both “Buffer Length” and “Latency Compensation”, but that didn’t change the behavior.

Any assistance in resolving this problem would be appreciated. Would reverting to an earlier version of Audacity work?

Thank you.

I got the same problem , but not sure it may be due to lower pc hardware i solved the problem is through selection tool, i have selected few minutes in bottom selection icon and applied the effect and continued multiple times on next minutes until track gets completed. this solved my problem.

Super, thanks! I’ll give that a try.

That worked, thanks! I’ll mark rangoonrowdy 's response as the resolution as soon as I submit this. Just wanted to say “thanks again”!!

This topic was automatically closed after 30 days. New replies are no longer allowed.