Apply Chain file export problem [SOLVED]

Hello, I’m running Audacity 2.0.0 on a MacBook Pro OS 10.6.8 and am having the following problem:

When I batch process some files using Apply Chain (using a chain that I have created myself) the edited files are not exported into the “cleaned” folder. The original files are “cleaned” and the “cleaned” folder is created, but it contains no files, and I’ve tried exporting both MP3 and WAV files without success. The Chain being applied has been created correctly.

I then tried the “CleanSpeech” chain that comes with Audacity and it did successfully export an MP3 file. Also, if I export a file normally (i.e. File > Export…) then both MP3 and WAV files are exported successfully.

This is a major problem as I have a lot of files that need batch processing, so please reply if you have any ideas what the problem might be!

Many thanks in advance.


The current version is 2.0.5 from Audacity ® | Download for Mac OS . I recommend you upgrade.

If you cannot solve the problem (see below) you may want to attach the Chain’s text file from ~/Library/Application Support/audacity/Chains. Use Go > Go to Folder in Finder to access that folder. Please see here for how to attach files: .

You can read how to edit a Chain here:
Audacity Manual .

Possibly you are out of disk space.

If you are using a Spotlight search, perhaps you are not searching correctly.

Perhaps you are not looking at the correct “Cleaned” folder. See Audacity Manual for the “rules” that determine the location of the “Cleaned” folder.


In reply to creativetype’s e-mail from Nabble, Batch Debug Mode is not enabled in Audacity 2.0.x and is not causing the export problem mentioned in this topic.



I upgraded to 2.0.5 and this solved the problem.

Thanks for the suggestion.