Any Way to Recover "Orphaned Files"?

Great suggestion, I’ll do that in the future.

Do you have a recommendation for the best PPA to use right now? I’m guessing the repo version would be fine, since it’s sounding like my issue isn’t likely to be fixed in the latest Audacity?

When I use my GUI sound control it tells me (on the Output tab) that I’m using “Built-in Audio Analog Stereo (echo cancelled with Built-in Audio Analog Stereo)”. Interestingly enough I just noticed that it says “Mono” in italics below that … even though the option above it (“Built-in Audio Analog Stereo”, with no echo cancellation) says “Stereo” in italics below.

I think one thing I could try (and probably should have already but didn’t think to) is switching that to the non-echo cancelled version (echo cancelling just sounded like a good thing, so I naively set it to that).

But to your question, I posed the entire Audio Device Info output above, and the section I think is relevant would be:

==============================
Device ID: 0
Device name: HDA Intel PCH: ALC892 Analog (hw:0,0)
Host name: ALSA
Recording channels: 2
Playback channels: 2
Low Recording Latency: 0.00870748
Low Playback Latency: 0.00870748
High Recording Latency: 0.0348299
High Playback Latency: 0.0348299
Supported Rates:
    44100
    48000
    96000
    192000
==============================



Well this gives me hope it’s solvable at least.

I expect that if you use “hw” settings for both the recording device and the playback device, the random freezing probably will miraculously disappear.

Probably the version that you’ve got now.

Weird.

So I found a problem: I don’t have a “‘hw’ device in the Audio Device Info that corresponds to the physical device that you use for playback” … or at least I didn’t.

I started to write this post, but then I had to do some work (which involved closing and then later opening Audacity).

When I came back, I did have an "HDA Intel PCH: ALC892 Analog (hw:0,0) option … and I’m now using that instead of “default”.

I’ll keep using Audacity and report back whether I still crash or not, but I’m curious if this disappearing option is related to my problem, or just a “red herring”?

As I wrote previously, ALSA drivers usually support only one client application at a time. If the device is busy (used by another application), it will not be available for Audacity. (“another application” includes your web browser, the PulseAudio mixer, and any other application that uses the sound card).
If, when you launch Audacity, the device you want to use is not listed, close all other audio applications and “Rescan Audio Devices” (in Audacity’s “Transport” menu).

Well I am very happy to report that switching my output device seems to have solved everything! Thanks everyone so much, it’s really night and day using Audacity now! I feel sort of like a PTSD victim after a catastrophe: because of before I keep expecting Audacity to crash, but the crash never comes :slight_smile:

I’ve had just one crash since, and when I checked it was because my device had gotten set back to Pulse, (away from the “hw:” option).

So now there’s just one last thing I’d like to know: why is Chrome such an jerk about randomly taking over my audio, and is there anything I can do about it?

I ask because it seems Chrome is what keeps breaking Audacity. However, I’m the kind of person who leaves lots of tabs open. I guess some of those tabs might have media in them, but it’s not like there’s an obvious “playing” tab to blame. It’s more like Chrome seems to just decide, at random intervals, to take over the audio, regardless of what tabs I have up (or possibly it does it if I have any media tabs whatsoever out of the 50+ I keep open).

It seems like it’d be really nice if Audacity could tell Linux “I’m the captain now: don’t give control of the audio to other programs”. But failing that, is there any way I (the user) can tell my system that Audacity is the boss, and Chrome should stop taking over?

I really don’t want to have to shut Chrome down to do audio work (for one thing, all of my “scripts” are kept in Google Slides).

I don’t think there’s any way to do that, but there is quite a neat little workaround.

  1. Buy a cheap USB sound card - it doesn’t matter if it is rubbish sound quality “dongle” style interface, any old thing will do. If you shop around you can probably pick one up for about $1.
  2. Set the cheap USB sound card as the default playback device (in “Sound Settings”).
    You can check that it’s the default by opening Chrome and going to a page that has sound. It will play through whatever is the default.
  3. Then in Audacity, set the recording and playback devices to the “hw” options for you main audio device (not the cheap USB thing).

If you do that, it doesn’t matter if Chrome grabs the sound card, because it will be grabbing the cheap USB thing, not the one that you are using with Audacity.

That’s a great idea, and I already have a cheap separate sound card for recording. However … won’t that mean that everything I watch on Youtube (or otherwise do in the browser) will use that crappy sound card? Also I use my computer’s built-in speakers, so I’m not even sure I can play through them using that sound card.

I may try doing that if I can’t find any other option, but it feels like there should be some way to tell Chrome “shut up until I want you to play (ie. when I don’t have Audacity open)”, and it’s frustrating that there doesn’t seem to be any.

Only while it’s plugged in.
When you’re not using Audacity, just unplug it.
Alternatively, you can switch which sound card is being used in “Sound Settings” (on Xubunu, I just click on the speaker icon and select “Sound Settings” - probably similar on other flavours of 'buntu / Debian / Mint).