Another noob Question

Hey everyone,

I’m new here having just discovered this site after downloading Audacity. I’m a drummer and have been recording with bands for years. Thought it was about time I had a go at playing on the other side of the desk as it were!

I picked up a cheapy 2nd hand Alesis DM5 kit for practice at home but decided I’d like to have a go at recording from the kit. I bought a Behringer 802 mixer which allowed me to play along with my ipod for rehearsal purposes. Then I purchased a Behringer UCA222 USB audio interface to allow me to record to the PC (Windows 7). Luckily enough a copy of Audacity came with this bit of kit. After a few initial problems that I managed to find answers to I thought I was good to go. Only, I can’t get the drum sound. All I get is the sound of pads being hit by sticks.

My Alesis goes into 1 channel of the mixer and then into the UCA222 which then goes into the PC. I can hear what I’m playing with the headphones connected to the UCA222 but Audacity only plays back the stick / pad sound.

The Alesis is connected from the main output sockets into 1 channel of the mixer. Should I be connecting from the auxiliary output into the mixer? Or is there something else I’m doing wrong?

I know there is a similar thread to this on the forum but I didn’t think it helped me.

Would be really grateful for any help?



Actually, having done some more research (and realising how little I know about this recording stuff) I’m thinking that I might be better off purchasing a USB / Midi interface and some drum software and using the midi output / input on the DM5 drum module.

Whilst I know Audacity doesn’t ‘do’ midi, presumably I can import triggered samples from whatever drum software into Audacity?

Anyone care to comment? I really am starting from scratch here… :blush:

That suggests that you are actually achieving a microphone recording of the sounds that exist in the room.

So, the “problem” lies between the UCA222 and the PC. I have no relevant practical experience of your equipment, just what I’ve learned reading posts on this forum. Try shutting everything down and unhook the UCA222 from the PC. Now re-boot the PC. Let it complete doing it’s startup stuff. Now connect the UCA222 to the PC. Does Windows recognise the device? (new device detected, drivers installed, device is ready: that kind of dialogue). If so, start Audacity. Can you find the UCA222 or a USB device of some kind in the Device Toolbar dropdown lists? If so, select that for input and try again. Best I can do. The real experts usually come online early-afternoon GMT (I’m UK based).

PGA, many thanks for your input. I will try that. I’m so inexperienced at this stuff even the simple fixes are beyond me at times.

Thanks again,


PS - I’m also UK based.

I attempted to answer this before …

The recording of the “real” (i.e. not electronic) sound of the pads being hit may be due to your computer’s built-in mic being enabled*, if the recording also includes swearing that’s definitely the case :slight_smile:

[* i.e. Audacity is recording from the computer’s built-in mic, which you don’t want, and isn’t recording from the USB device which you do, see your Windows mixer to enable the USB audio device and disable the onboard microphone … ]

Theoretically Audacity can record whatever is playing on the computer, e.g. sound synthesized by the computer triggered by the drum pads via midi interface, however some incarnations of Windows-7 apparently do not have record “what-U-hear” aka “stereo mix” aka “wave out”, (

Thanks Trebor, appreciate your help.

And yup, it picked up swearing, huffing and puffing etc… :open_mouth:

However, I’m convinced I sorted the PC issue out but I will try what AGB suggested because I definitely didn’t look at that!

Thanks again,



Thanks for the tips.

I got home and did as you both suggested. Disabled the mic in windows and enabled the correct device in Audacity. I actually recorded something. :smiley:

Now I gotta find out how to get rid of the distortion, clipping and delay!

I reduced the input and output levels on the top toolbar thinking this would help but it didn’t. Back to the manual methinks…

You’re not feeding the line-out signal from the electronic drums into the computer’s microphone socket ?
as that’s almost guaranteed to cause severe clipping distortion.

If there isn’t a line-in socket on your computer use the UCA222 to connect the drums to the computer.

No, the drums are fed into the 802 mixing unit which is then going into the UCA222 which in turn goes into the PC. I need to check all the levels on the mixing unit in case these are set too high. It’s all I can think of now…

There may be a “gain” or “level” slider within the Windows mixer recording tab [see “properties”] for the USB (UCA222) which you can turn down.