Another newbie needs help with USB Tape Deck

I’m running Audacity 2.1.0 on a 2011 iMac running 10.10.3 Yosemite. I am trying to record from a Tape2USB deck. I have followed the instructions for set-up, usb out to usb port on computer, USB Audio CODEC on the input, and USB Audio CODEC highlighted in System Preferences, Sound, Input. I press the record button in Audacity, play the tape, can hear the tape on the Tape Deck’s output, but no recording levels are monitored, and no lines jumping around signifying that Audacity is “hearing” the tape. It’s not receiving the input. What am I doing wrong? Thank you.

Let’s step back and make sure that the tape deck is communicating with the Mac.

Go to Apple Menu > System Preferences > Sound > Input.
Select the USB Audio CODEC, which should be the tape deck.
Play a tape. Does the sound meter show an input being received?
If not, we need to figure out what’s wrong.
If yes, then we’ll move on to investigating the settings in Audacity.

You say you pressed the record button in Audacity, but did you set the USB Audio CODEC as the input in Audacity?
See this page in the manual about the Device Toolbar.

– Bill

No to the first, yes to the second.

I went to System Preferences, Sound, Input, and highlighted USB Audio CODEC and played the tape. I’m not sure which sound meter you’re referring to, whether it’s the one in Sound or Audacity, but neither shows anything.
Under the box that says, “Select a device for sound input:” and all the choices, from which I highlighted USB Audiio CODEC, it says:

Settings for the selected device:
and below that,it says, “The selected device has no input controls” and below that is perhaps the sound meter you’re referring to, which registers no input.

So the problem probably begins here.
Hope this is clear.

And yes, I did set the USB Audio CODEC as the input in Audacity.
Thanks for your help so far.

You can close Audacity for a while. It gets its sound from the Mac. If the Mac can’t find the player (System Preferences), that’s the end of the story.


Well, that was a pretty grim assessment. After trying a different USB port to no avail, I took out the USB cord, and connected the tape deck to the computer with an RCA cable, from Play Output, Red and White, to the input on the computer next to the headset. I changed the sound input in System Preferences/Sound to Line in, and Output to Built-in Internal Speakers. I’m glad to say that at least now the Mac is receiving input from the tape deck. It doesn’t sound too good, but at least it’s reading.
I’ve tried fooling around with the rec level on the tape deck, and in Audacity. It doesn’t seem to matter to Audacity if the Rec level on the tape deck is all the way up or all the way down. If the Rec level on Audacity is low, (0.00) I hear no hum, but as soon as the Rec level goes up, there is a hum, that gets louder as the Rec level goes up to 1.0. But without the loud hum, the dB line barely moves, and the recording is very faint. When I turn up the Rec level to 1.0, I can hear the recording, but it has the hum, and still sounds tinny and inferior to the sound of the tape I’m recording.
But at least my computer can “read” the tape deck, with the RCA cord.
So my next questions would have to do with how to set the Rec levels.
Thanks for your help

Which USB tape deck are you using? An Ion?

Some of these are still real USB 1.1 devices. That results sometimes in problems with USB3 ports. Now I think you are using a USB2 port and that doesn’t mean a problem afaik. But just on the odd chance it might help, do you have a USB hub? Try inserting it between the Mac and the USB deck?

My tap dancing teacher leant me his tape deck. It’s a Grace Digital Audio Tape2USB. I wouldn’t be surprised if it’s old, because the Audacity disk that came with it was older than the one I had downloaded. It was 1. something.
I do have a USB hub, and I will try it and get back to you. Thank you.

Thanks you thank you thank you Cyrano. I have Win7 and an ASUS sound card, but could not get any sound into Audacity from my brother’s Grace Tape2USB player. I had no idea there could be problems using USB 3.0 with the older USB 1.0 devices. Sure enough, I found a USB 2.0 plug on my mother board back panel, plugged in the Grace to that, then Win7 downloaded the usb audio codec, and I am now happily recording! Thanks again.