Another "Error opening sound device" question

The recent Win 10 updated seems to have affected Audacity with the “Error opening sound device” popup at every start

Prior to the Win 10 update I was running Audacity 2.2.1 but as part of the attempt to fix this problem, have installed Audacity version 2.2.2. My soundcard is a SB ZxR which is operating normally (software was updated in May, everything had been working properly and continues to work). The error is with respect to line input. haven’t tried the SB microphone input as I rarely use it.

I tried the usual fixes per this and other sites:
Playback and Recording sound devices are selected and enabled (both recording & playback device is “Soundblaster ZxR”.);
Sample rate is the same on card and Audacity (44.1kHz);
Tried all of the audio host settings (MME, Windows WASAPI, Windows Direct Sound);
Checked that “Software Playthough” was turned off in Audacity Preferences;
Restarted Windows Audio Endpoint Builder service;
Played around with all the settings several times, restarting Audacity each time. Also restarted the computer a couple of times, most recently after the Endpoint Builder service was completed;
All of the above was performed multiple times and in multiple combinations.

My external computer speakers (JBL LSR305) continue to work fine whether I pop in a CD, stream something from Napster or watch a Youtube video. I’m not particularly computer savvy nor am I a very experienced Audacity user, so appreciate any and all suggestions.

See this thread:

OK, after performing ALL suggested fixes, from the Audacity site and myriad other web sources, I still got the “Error opening sound device.” In a last ditch effort, and even though I’m using line, rather than microphone input, I tried enabling the Microphone from the Settings/security panel. This was a limited success: Audacity opens and runs however, the recording level is on the order of -25 or -30 db, despite the Audacity record slider being turned up full.

I first thought that it was somehow recording live via the desktop internal microphone (I’m assuming there is one somewhere but don’t know this for sure - I would use the SB mic if needed but don’t have anything connected at the moment). I don’t think that’s what’s happening however, as the fidelity is rather good, as far as I can tell, the equivalent of what you’d get via line in.

Any ideas of what’s going on here? Appreciate any and all suggestions

Audacity was working great for me, then I lent a friend my usb audio interface for a few months. When he returned it, Audacity gave me the following message every time I tried to record: error opening sound device try changing audio host, recording device and project sample rate.

For Windows 10 - The solution was hit the window key and the i key at the same time, which opens settings, then click on “privacy”. Along the left side click on “microphone” (note - I was trying to use line audio through a USB interface, not a microphone, but why would windows call an audio setting “audio”? That would make it too clear.) Now, above the word “change” it should read “microphone access for this device is on.” If not, click change and turn it on. Then, under “allow apps to access your microphone”, the switch should be ON. Below that is a list of apps. I suggest you turn off all that you don’t want accessing your audio. Audacity is not listed. I have Skype installed so made that the one app that can access the “microphone”.

I had this problem on two Windows 10 pcs, and this was the answer on both. On my partners PC all was well.

This is also discussed here, but because it doesn’t list the error message I was getting, I had no way to search for this answer. I hope this helps everyone!

Thanks for that helpful feedback Mikey - I have added the following to that original post that I made:

Update: you may also need to do this if Audacity was working on Windows previously but you now get the “Error opening sound device ….” message.


A while back I did also add to the FAQ in the Manual about the “Error opening sound device” error:

But unfortunately this will only be visible in the Manual for the upcoming 2.3.0 release - as we cannot edit the Manual for release versions once the release has been made.