Annoying Gaps

I am using a MacPro 5,1 10.13.6 and Audacity 3.0.2 and attempting to digitize my LP collection to iTunes. I did one side of an LP and when I played it back there were annoying gaps in the sound. I read somewhere that I should quit all other applications to avoid those gaps. I quit all apps except Audacity and still got gaps. What should I try?

Take a screen grab of the Activity Monitor and post here.
Maybe there is still something consuming lots of CPU cycles or memory.

Go > Utilities > Activity Monitor.

Select CPU.

Shift+Command+4 and draw a box around the display.

Scroll down from a forum text window > Attachments > Add Files.


Thank you for the suggestion. I just recorded a section but there were no gaps and of course the Activity Monitor indicated that the only apps using resources were Audacity generally under 30% and Activity Monitor generally under 2%. If I catch another gap I’ll check Activity Monitor and if I’m still puzzled I’ll post again. Once again thanks!

Audacity generally under 30% and Activity Monitor generally under 2%.

I don’t know how to solve this, but the overall percentage doesn’t tell the whole story… If some application, process, or driver, “hogs” the system for a few milliseconds too long, you get buffer overflow and a dropout/glitch. (During playback you can get buffer underflow if the buffer isn’t re-filled in time.)

A common cause of little gaps on Mac is the audio buffer settings. See: How can I prevent clicky recordings on Mac?

Thanks Steve! That solved my problem. No gaps now. I changed it to 0 and all is good. :slight_smile:

My MacBook Pro 14" is on Monterey version 12.1, with Audacity version 3.1.3.

I’m having issues with audio dropouts only on playback, and have used Audacity for years without any issue. I record audio using Traktor with an S2 mk3 controller. I edit the audio using the laptop and a connected RME Fireface UCX interface.

Although the laptop is new since November 2021, I have recorded a couple of one hour mixes since then with no problems. The audio file today is from a two hour mix, and I have scrubbed back where a dropout occurs, played the audio again and it doesn’t happen again at the same point. I also played the original recording using Quicktime, and didn’t hear any dropouts.

So this appears to be a playback-only issue. I reviewed the manual and changed the device latency to 0ms. This helped, but the dropouts still occur, just not as frequently. I also noticed that the file was recorded at 48,000hz. I only need it to be 44,100hz and have changed this in Traktor Preferences, but would still like to edit this two hour audio file.

A few things are different from the last time I recorded and edited audio: I was using Audacity version 3.1.2 last time, and the audio file was only one hour. I suppose another test I could run is to play back a previous one hour recording to see if there are any dropouts. Then that might point to the file size being an issue, and if not, perhaps it’s something to do with the new Audacity version? And last time, Monterey was on version 12.01, and now it’s 12.1.

Any suggestions or comments welcome. I reviewed the latency test page, but that seemed to be applicable to recording audio, which isn’t the issue I’m having. Also attached are screenshots of Activity Monitor taken shortly after one of the audio dropouts. Thanks much!
Screenshot 2022-01-16 at 16.41.17.jpg
Screenshot 2022-01-16 at 16.41.04.jpg

That’s noteworthy.

Screen Shot 2022-01-16 at 10.48.14 AM.png
Audacity, even when it’s busy, is not supposed to run at 100% CPU load. Something is causing extreme activity.

I just played back an ordinary stereo show into my sound system.

Screen Shot 2022-01-16 at 10.59.08 AM.png
That’s more better.

You may be able to get Audacity pounding on the machine if it’s playing through recursive sound pathways or through other software packages.

When was the last time you restarted your Mac? I used to get one of the supervisors at work out of trouble by closing the 30 or 40 applications he left running in the background.


The audio dropouts were still occurring after a reboot, so I resampled the two hour audio file from 48,000hz to 44,1000hz. I also set the latency back to 100ms, and now the issue seems to be resolved with Audacity running at about 40% in Activity Monitor.

Perhaps a two hour 48,000hz audio file was just pushing the limits. Should there be any further issues, will update here accordingly. Thanks for the suggestions!