Annoying clicks...

Running Yosemite (10.10.2) with Mackie Onyx firewire interface and I’m getting loads of little high freq clicks on playback.
When I edit and process thankfully the clicks are recorded!
Tried Audacity 2.1.0 thinking it would solve the problem but it didn’t.

Any one have this problem?


Mistake in message:

Meant to say:
"thankfully the clicks are NOT recorded "


What type of Mac is it exactly? If it is running on battery, does plugging it in help?

What is the exact model number of the Mackie? Do you need drivers for it from It seems from that page that Mackie does not support Yosemite.

Have you tried Audacity > Preferences… then the Recording section, and adjusting “Audio to buffer”? Try reducing or increasing it.

What project rate do you have bottom left of Audacity? Have you chosen a project rate supported by the Mackie and have you opened /Applications/Utilities/Audio MIDI Setup and set Mackie input and output to the exact same rate you chose in Audacity?


Hi Gale
Thanks for your post.
I’m running a MacPro quad core
The Mackie onyx is one of the new ones that doesn’t need drivers as the Apple OS has that covered.
Tried altering the buffer setting with no difference.
Project rates all matching.
I’ve contacted mackie support but that can be quite a wait…
For the sound files that I need to analyse and process I am going to use my DAW (Logic) as I need to crack on.

Kind regards

When you have more time you could perhaps try experimenting further, perhaps taking the buffer as low as it will go without the sound breaking up. That definitely works for some people.

Thanks for the report.