Andrea Mic gets 9999 Error Code

Hello. I am running Windows 11 on my new laptop I just set up with an Andrea Pureaudio mic. Audacity has run well for me on my previous laptops, though they were running Windows 10.
This is the second thing I have installed, after Firefox. This is the second time I have installed it, as I reset the computer when it didn’t work the first time.

I have checked permissions, reinstalled, shut off and on, run troubleshooter but nothing has worked. It works if I am using the internal mic, but not the Andrea mic, yet this has never been a problem in the past.

Don’t know if this helps, but these are my problem details:
{
“timestamp”: 1710398541,
“event_id”: “19d6ae962963b74ba46302ad7449a8a3”,
“platform”: “native”,
“release”: “audacity@3.4.2”,
“contexts”: {
“os”: {
“type”: “os”,
“name”: “Windows”,
“version”: “10.0.22621”
}
},
“exception”: {
“values”: [
{
“type”: “Error”,
“value”: “Error opening recording device.\nError code: -9999 Unanticipated host error.”,
“mechanism”: {
“type”: “runtime_error”,
“handled”: false
}
}
]
}
}

Any help or suggestions? Thank you!

Edit: I just went to my Microphone Access by App page in settings, and Audacity is not there, even though I have it as an app. Thanks again!

Edit II: Under my recent activity on the microphone page, it says none have tried to access my microphone, but I did try and record with Audacity.