Amplitude Graphic Invisible - Latency Error?

Win7 pro - just (re)installed 2.1.1 - installer.exe
I don’t know terms of recording or Audacity controls very well. The graphic that shows sound mix amplitude suddenly vanished. Audacity box “pulses” as if it is recording but two track display is empty - it may be recording but I have no control over volume and clipping. This just suddenly happened. I’ve been using Aud to capture inet streams over integrated sound card Realtek using WASAPI in AMD APU. I saw an error msg that said something about the latency of the stream and I can invoke the time shift tool (if that is the corrective measure), but I don not know how to use it. This prob was occurring in ver 2.0.5 so I uninstalled and dl/installed the new version. should I have wiped the old settings?

Very frustrating. Audacity works so reliably and easily on other system making beautiful clear stereo analog recordings of stream capture on primitive 2-core XP using v1.2.6 that I do not want to touch it as it is my spare tire. HDDs are 70% empty. I use Applian Replay most of the time but make occasional sound card recordings using Audacity when I can’t grab the URL packet stream. I erase or transfer recordings daily.

Apologies if this is a common problem already answered in other dialog. I did some searches but may have used wrong terms.

With WASAPI loopback recording, make sure the stream is playing before you press the Record button.

If you see the message about Latency Correction, it means the recording has stalled. Because you have Transport > Overdub on, Audacity pushes the recording backwards but because the recording is only a fraction of a second long, Audacity pushes all of it behind time zero and then warns about that.

Try turning Transport > Overdub off. Try setting the Audacity Project Rate (bottom left of Audacity) to 44100 Hz. Then set “Default Format” for your playback device in Windows Sound to 44100 Hz, with both “Exclusive Mode” boxes unchecked. Quit Applian Replay while trying to record using Audacity.

If your Realtek device has stereo mix, you can also try enabling stereo mix in the Recording tab of Windows Sound (right-click in empty space and choose “Show Disabled Devices” to see if stereo mix exists). Then restart Audacity and change the Audacity recording device to stereo mix.

You may find that simply restarting the computer cures the problem.

Disclaimer: Please always ensure you have copyright holders’ permission before capturing internet streams.


Thanks for Help. I turned overdub off set project and sound system to 44100, and made sure I was in WASAPI - HiDef audio (loopback) - Stereo - Hi Def output.

Now I get a blue graphic display but it is a flatline as if volume was zero. Vol is near max in Windows Realtek sound, likewise in Mix, and perfectly audible from speakers. Aud is somehow disconnected from speaker output. I cannot reboot right now. I will try that in a few hours after daily processes are finished.

Project rate reverts to 48000 after exiting audacity.


After some digging I found I had to goto the system volume control in task bar, click on recording devices, find disabled devices, ENABLE STEREO MIX. Now recording works as expected. Why it was recording before without StereoMix, I will never know. Perhaps something was modified with the Tuesday (2 days ago) security and maint patches.

The Windows WASAPI (loopback) input that you were trying to use before does not depend on stereo mix.

If you receive erratic behaviour, it may be worth reading Missing features - Audacity Support in case you don’t have proper up-to-date drivers. In the case of a Realtek built-in sound device that means going to the web site of your computer manufacturer to see if you have the latest audio drivers for your computer model.