All .WAV renders start with a sample set to 0.

Hello, I am a long time user of Audacity and this is my first issue with the program.

The system I am currently running Audacity on is Windows 8.1. The version of Audacity I am running is 2.1.3.

I am using the amazing Experession Generator plugin to generate sets of data that I am rendering out to .WAV format. Specifically Microsoft signed 16-bit PCM.

I need to have a falling exponential data set where the first sample is set to 1. Here is what that looks like in Audacity.
Exp Fall.png
After rendering the .WAV, here is what is looks like in Audacity up close. It appears as if there is no error after reloading the rendered .WAV.
Exp Fall Audacity Closeup.png
Here is what the same .WAV looks like in the audio editor Edison. It very clearly shows the sudden jump from 1 to 0 then back to 1.
Exp Fall Edison Closeup.png
I am not sure why the .WAV is being rendered out this way. I have tried with a variety of formats including .ogg and .flac, and they all have the same issue. I have also edited .WAV files that were not generated in Audacity to have a non zero starting sample, and they all have this same error after being rendered.

Please let me know if you need any more info. Also please let me know if I am just bing stupid and that all audio files must start with a zero sample.

In 2.2.0-alpha if I export three samples at +1, 0 and 0 respectively as 16-bit PCM WAV and import that file as Import Audio, I get three samples at +1, 0 and 0 respectively.

If you are using Import Raw Data and entering wrong data for the file that could be an explanation.

The current Audacity release version is 2.1.3


Just to confirm, Audacity is not the cause of this issue. I also love the look of the new alpha version. :slight_smile:
Recreating the data set Gale suggested and reading it back in an oscilloscope confirms that the data set Audacity shows is what SHOULD be rendered by other programs.
Some programs seem to display the last zero delimiter of the WAV header, but they never actually play it back. Sorry it took a few days to sit down and have time to test this throughly. I would assume most audio editors do not realize this as most sets of audio data start at 0 anyway.

Thanks to Gale’s suggestion, I did have a lot of fun importing and exporting different types of audio files using raw import and audio export to see if any strange combinations could fix the issue in the external visualizer.

I don’t know the program “Edison”, but are you sure that is what it is showing? It looks to me to be a similar thing to Audacity’s “clipping” indicator (