All speaker sound is being recorded. (SOLVED)

Hi, first of all, I apologize, because I realize this is probably an insanely simple issue to resolve.

I’m attempting to record multi-track music from a Roland AX synth into Audacity (which is up-to-date). My OS is Windows XP, with a Realtek HD sound card. I’m plugging the keyboard directly into the sound card’s line-in using a 3.5mm to 6.35mm cable.

Whenever I try to record, the sound from the instrument is being recorded, but so is every other sound made by the speakers. For instance, if I open the start menu, the noise from its opening is recorded. This obviously becomes a huge problem for overdubbing, as all of the previously recorded tracks get recorded into the current track.

My settings are this:

In the Realtek HD Audio Manager, the speakers are assigned to “line-out”, and the keyboard is assigned to “line-in”, although the same problem occurs if it’s assigned to “mic”.

In Audacity, my playback option is “Realtek HD Audio Output” and my recording option is “Realtek HD Audio Input: Line-In”. The only other option, in both cases, is “Microsoft Sound Mapper” which records absolutely nothing. Overdub is checked, and Software Playthrough is unchecked. (It’s worth noting that while I don’t get the problem when Overdub is unchecked, that also means that I can’t hear what I’m playing while I’m playing it, utterly destroying any chance at precision.)

Long story short, is there any way to get Audacity to record just the sound from the line-in, without also recording all of the other sounds from the line-out, which is what it appears to be doing.

Apologies for my ineptitude with this software, and thanks a lot for any help.

In the Transport menu, “Overdub” should be on (selected) and “Software Playthrough” off (not selected).

It sounds like your computer is recording “Stereo Mix” even though you say that the Realtek HD Audio Manager is set to record “Line In”. :confused:
Check in the “Windows Mixer” (usually available as a yellow loudspeaker icon near the time/date, but otherwise may be accessed through the Windows Control Panel). It could be that the Windows Mixer is overriding the Realtek HD Audio Manager settings.

Also check very carefully that “Stereo Mix” is not enabled in the Realtek HD Audio Manager. Unfortunately there are hundreds of different of the Realtek HD Audio Manager with settings hidden in different places so it is difficult to give precise instructions.

Try searching Google for “Realtek HD Audio Manager stereo mix” (without quotes). You will find numerous articles about how to enable Stereo Mix for different versions of Realtek HD Audio Manager. You need to do the opposite and disable Stereo Mix.

Brilliant, thanks so much. Stereo Mix wasn’t muted in the Realtek control panel, so I’ve set it to mute and now the problem’s not cropping up anymore. Thanks once again!