All available memory consumed quickly

When recording in Audacity, all my memory gets quickly eaten up. I have multiple machines but slightly different setups but only one of them is having the issue. Here is the one having the issue:

antergos/arch, kernel 5.6.13, audacity 2.3.3 and 2.4.0, 7th gen i7 processor, 16gb ram, 8gb swap
system memory goes from 3gb to 16gb in 5 minutes. then from 0 to 8gb swap in 4 more minutes.
then the machine freezes or audacity silently quits
if stopping the recording mid way, memory use does not change - even if I delete the track. but when I close the project, the memory is released.
I have tried recording in to my internal stereo input on the computer and also into a USB audio cable with the same results

Here are two other Linux setups that are NOT having problems:

ubuntu 16, kernel 4.15.0 audacity 2.2.1, 7th gen i7 processor, 24gb ram, 1gb swap
system memory use never goes above 3.4gb and swap never gets used

manjaro/arch, i7, 5.6.11 kernel, audacity 2.3.3, 16gb ram, no swap
system never uses more then 1.6gb memory

I have run audacity from the terminal in case there are any errors streaming out while the memory usage goes up, but I’m not seeing any. Any tips on how I would go about determining the issue? I have tried using other recording software on the affected machine and that has no problem. I have also started compiling other versions of audacity locally but I’m guessing thats not going to get me anywhere.

By default, Audacity records as stereo 32-bit float PCM at 44100 samples per second.
That’s 4 bytes per sample, and 2 channels = 4 * 2 * 44100 = 352800 bytes per second, which is approximately 20 MB per minute. I can’t see where you can be getting 13 GB of data in 5 minutes.

Did you compile Audacity yourself on this machine?

I did not compile this version myself.
It should not be recording to memory, since it uses a temp dir. But even if it did use memory only, 20mb * 5 minutes is only 100mb.
Also notice that on the other machines it never uses more then 1gb of the system. Even if I record for hours, memory use does not change on those ones.
I have also lowered the bit rate and samples when recording to see if it helps. Memory still maxes out.

Where did you get it from?
Which version is it?

I have tried 2.4.1 and 2.3.3.
These are official packages from the Arch maintainers:

Here is how 2.4 is packaged:

I also checked the package from Manjaro where I am not having trouble. The checksum for 2.3.3 is the same as it is on my Antergos machine where the problem is. So the binary is identical. Which makes me think its either the system configuration or perhaps a dynamically loaded library?

Sorry but I can’t think of any way to make Audacity use that much memory even if I wanted to.

A Google search for “antergos ram crash” suggested this page:
but the website can’t be found.
Their official website “” can’t be found either. Is this distro still active? Do they have a working support channel?