ALAC Output Issue

Greeting to all,
I’m using Audacity 2.3.3 on a Windows 10 PC.

I’m trying to export a vinyl album recorded as a single WAV file to multiple ALAC files using the following command line

“C:\Program Files (x86)\Audacity\ffmpeg\ffmpeg.exe” -i - -acodec alac “%f”

Unfortunately it fails with the following error

“C:\Program Files (x86)\Audacity\ffmpeg\ffmpeg.exe” -i - -acodec alac “E:\Music Files\ALAC Files\Motorhead\2013 Aftershock\01-Heartbreaker”

ffmpeg version 2.2.2 Copyright (c) 2000-2014 the FFmpeg developers
built on May 22 2014 19:56:44 with gcc 4.8.2 (GCC)
configuration: --disable-static --enable-shared --enable-gpl --enable-version3 --disable-w32threads --enable-avisynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enable-iconv --enable-libass --enable-libbluray --enable-libcaca --enable-libfreetype --enable-libgme --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxavs --enable-libxvid --enable-decklink --enable-zlib
libavutil 52. 66.100 / 52. 66.100
libavcodec 55. 52.102 / 55. 52.102
libavformat 55. 33.100 / 55. 33.100
libavdevice 55. 10.100 / 55. 10.100
libavfilter 4. 2.100 / 4. 2.100
libswscale 2. 5.102 / 2. 5.102
libswresample 0. 18.100 / 0. 18.100
libpostproc 52. 3.100 / 52. 3.100
Guessed Channel Layout for Input Stream #0.0 : stereo
Input #0, wav, from ‘pipe:’:
Duration: N/A, bitrate: 1411 kb/s
Stream #0:0: Audio: pcm_s16le ([1][0][0][0] / 0x0001), 44100 Hz, stereo, s16, 1411 kb/s
[NULL @ 02851400] Unable to find a suitable output format for ‘E:\Music Files\ALAC Files\Motorhead\2013 Aftershock\01-Heartbreaker’
E:\Music Files\ALAC Files\Motorhead\2013 Aftershock\01-Heartbreaker: Invalid argument
Conversion failed!

Any thoughts please on where I’ve gone awry?



Have you tried it the “normal way” (GUI)?

I’ve never used the command line with Audacity but “Custom FFmpeg Export” works for me.

[EDIT] -
Or maybe not… I got a playable file, but I couldn’t select the bit depth and MediaInfo says I got a 16-bit, 44.1Khz, stereo file with a bitrate of 1395kbps which is almost no compression!

TAudioConverter gives me 885kbps which is more like it.

Thank for the advice, sadly it’s not what I was looking for

I would like to know why the command line entered above isn’t producing the desired output
its based upon:

Here is an example of a command to FFmpeg in an arbitrary location on Windows, forcing the exported codec to Apple lossless. When specifying the file name above the command, add the extension “.m4a” (without quotes), not .alac:

“E:\FFmpeg for Audacity\ffmpeg.exe” -i - -acodec alac “%f”

Taken from


Greetings to all,
I’m delighted to advise this issue has been solved thanks to my daughter and her sound engineering degree.

When exporting a single WAV file to ALAc a box a box appears allowing the .m4a suffix to be added to the filename.

When Exporting multiple files the .m4a suffix must be added to each label.

I hope this may help someone.