Add silence from length

There is a way (in 2.1.2) to not write metadata, which is to press “Clear” in Metadata Editor when it pops up at export. Or if you have hidden Metadata Editor for the export step in Import/Export Preferences, then File > Edit Metadata and press “Clear” before you export.

“Clear” is supposed to write no tags, not just empty tags, but I see this has gone wrong somewhere between 2.1.2 and now (2.1.3 alpha). Pressing Clear in 2.1.3 alpha still writes empty ID3 tags. This applies to ID3 tags in WAV too.



I don’t understand how that helps. For the 3000 files that deafwench needs to export, isn’t it still necessary to either have the Metadata Editor pop-up and “Clear” it 3000 times, or File > Edit Metadata and press “Clear” before you export 3000 times?

Most users probably don’t need to export thousands of files in a row, but over a period of time it is an annoyance for those that don’t want metadata in their exported files. There should be a way to turn off writing metadata to exported files, but there isn’t as far as I can see.

Repetitive exporting is exactly the reason why needs to be fixed.

Just as users don’t want an extra “Clear” step to prevent metadata export, users who do want metadata export in Export Multiple don’t want extra steps. :cry:

So I look forward to your planned “No metadata” checkbox and your fix for bug 551 as extensively discussed. :wink: