Acer Aspire 5 playback choppy when recording

Computer: Acer Aspire 5 laptop purchased in 2023
OS: Windows 11
Audacity version: 3.3.1 and 3.3.2
Audio device: any audio device supported by the laptop, including the built in audio, driver is up to date
Audio host: MME
Problem: playback alone works fine. Recording alone works fine. As soon as I use Shift-R to playback and record at the same time, the playback becomes very choppy. The meter display shows output waveform but the sound becomes either distorted or cut-off completely.
I contacted Acer support. The representative says it is the problem of the application, not the problem of the computer hardware or device driver.
Extra information: I can use Windows WASAPI to record music played by the computer. It is just Overdub does not work. I tested the same version of Audacity 3.3.1 and 3.3.2 on an HP laptop running Windows 11, and there is no problem there.

Increase the buffer size: Go to “Edit” → “Preferences” → “Recording” and increase the “Latency” or “Buffer Size” to a higher value. This can help improve the playback quality.

Adjust the sample rate: Try adjusting the sample rate to a lower value. Go to “Edit” → “Preferences” → “Quality” and change the “Default Sample Rate” to a lower value.

Close other applications: Closing other applications that are running on your computer can help free up system resources and improve the performance of Audacity.

Update your audio driver: Make sure you have the latest audio driver installed for your Acer Aspire 5. Check the manufacturer’s website for any available updates.

Use an external microphone: If you are using the built-in microphone on your laptop, consider using an external microphone. This can help improve the quality of your recordings and reduce the strain on your system resources.

I hope these suggestions help you resolve the choppy playback issue in Audacity.

This topic was automatically closed after 30 days. New replies are no longer allowed.