7 speaker audio file

I am currently working on an audio installation project where 7 tracks should play through 7 speakers. Each track will have it’s own speaker. I have an AMP with 7 speakers outputs and DVD player. I have prepared a file in Audacity that I thought would play each track through each speaker but it only goes as far as playing the first track through speaker Front A Left and then the second track through Front B Right. It then doesn’t play anymore tracks through any of the speakers. I have scanned the various forums and help guides but no luck so far finding a solution. Does anyone know how I might fix this? I would really appreciate the help as my deadline is looming… it might be a hardware set up issues or it could be something I’m not doing in Audacity, a sense check would be really helpful. This is how I have set the file up in Audacity:

MAC OS X 10.9.3 (13D65)
Audacity ® 2.0.0 (Unicode)
Preferences / Import/Export I have selected ‘Use Custom Mix’
Each track is set to Mono from the title drop down menu
Exported to .WAV, when prompted I have checked there are 7 channels
Then burned a DVD

Audacity can produce multi-channel files (using “Custom Mix”), but Audacity can only play mono (one channel) or stereo (2 channels).

I don’t use a Mac so I’m not familiar with Mac software. Perhaps QuickTime can play multi-channel audio files?

I don’t want to use Audacity to play the file, I am burning the .WAV file to DVD and playing through a DVD player hooked up to an AMP with 7 speakers. This is the tutorial I have used to create the .WAV file http://www.youtube.com/watch?v=zu37UaVlLJE but it’s not playing through all 7 speakers only the first 2 tracks through 2 speakers.

I have attached a screen grab of the custom mix setting on my computer. I don’t think it should matter whether the version of Audacity is MAC or PC. I really hope you or someone can help out with this, I must be doing something wrong somewhere.
Screen Shot 2014-06-26 at 07.32.08.png

I only skimmed through that video, but I’m not sure he has got it quite right - his channel mapping looks wrong (though I may have skipped over the explanation of why he did it that way).

Some links from the manual:

Please post a screenshot of your “Advanced Mixing Options” (third link above).