3.4 crash when importing/exporting opus


reason why i updated (EDIT hidden)

audacity worked flawless for me before, but today i opened audacity 3.3.3 and it complained about being unable to locate ffmpeg for the first time. i could not open/import an opus file anymore. but it offered to update to audacity 3.4.

just did this, cleared all settings and tried again.

audacity immediately crashes when i try to open or import an opus file.

could not send crash report (EDIT hidden)

do i want to send a report? yes

here is the log:

crash.txt (144.0 KB)

may i assume that audacity was compiled with a certain instruction set that does not run on my cpu?

Intel(R) Atom™ x5-Z8350 CPU @ 1.44GHz 1.44 GHz

I don’t use opus much, but I just Exported one and was able to import it with no difficulties in Audacity 3.4.0.

(My Audacity log shows that I am using FFmpeg For Audacity\avformat-59.dll)

Will your file to convert to WAV using an online OPUS to WAV converter service ?

yes, and it’s a valid file - MediaInfo:


Complete name : D:\Downloads\Waiting for You.opus
Format : Ogg
File size : 2.73 MiB
Duration : 2 min 59 s
Overall bit rate : 128 kb/s


ID : 2768557878 (0xA504D736)
Format : Opus
Duration : 2 min 59 s
Channel(s) : 2 channels
Channel layout : L R
Sampling rate : 48.0 kHz
Compression mode : Lossy

currently i don’t have ffmpeg, audacity ships ogg.dll and opus.dll out of the box.

export to opus also causes a crash
crash2.txt (108.2 KB)

Please report this problem to the developers here: Issues · audacity/audacity · GitHub

Thank you for your report! Here is a relevant GitHub issue: WIN64 Opus is built with AVX · Issue #5516 · audacity/audacity · GitHub

This topic was automatically closed after 30 days. New replies are no longer allowed.