3.3.3 won't register in Win 7

Been using Audacity 2.whatever for years now - recently upgraded to 3.3.3 - worked fine then, but yesterday when I opened an MP3 using ‘Open With’ , the old 2.whatever launched. Finally uninstalled 2._ and tried ‘Open With’, and Audacity was not in the list. Clicked ‘Choose Default Program’ and it wasn’t in that list either - Had to browse to the .exe file in my programs folder, but instead of launching Audacity, the MP3 opened in Winamp (my default MP3 player). Finally uninstalled 3.3.3 and re-installed it, but still did the same thing. Even tried OpenWithAdd to add Audacity to the registry, but still behaves the same.

Just so you know, Audacity automatically associates with .AUP and .AUP3 files, NOT with .MP3 files.

I remember years ago fighting with Win7 file associations, so I don’t envy you. Let me suggest changing the MP3 association so it opens Audacity by default: Change which programs Windows 7 uses by default - Microsoft Support
then repeating the process for Winamp. I am hoping this will leave Audacity as an Open with candidate.

Tried all that, to no avail - tried uninstalling and re-installing 3.3.3 - Finally uninstalled 3.3.3 and installed 2.3.1 and it registered in Win 7 fine - associates with wav and mp3 as it should. So the problem seems to be particularly with 3.3.3 and Win 7 - 3.3.3 associates fine with Win 8 and 10.

So if y’all are concerned about backward-compatibility, you might want to pass this along

Thanks for all you do - Audacity is an awesome product!