3.2.5 cannot save to disk

Hello. I just allowed windows 10 audacity to update itself to 3.2.5. For a first project on this version I recorded a 50 minute LP. When I went to save it tells me it cant save to D drive as it is full. So I switched to my Synology NAS and it tells me that is full too. Tried the system C drive… no dice. Each drive has multiple free terabytes of space. Messages is Audacity failed to write to a file.

So then I tried to save a WAV file not to lose the work… It goes through the entire process to save the wav file and after a minute of two it says it cant complete the process… to try another drive. Nothing was written to the specified file when I check file explorer.

Would anyone have any ideas how to fix this other than killing the app and starting over? I sent a pile of error messages into the reporting system.

Using windows 10 19045.2604

Where can I download the audacity file to reinstall the previous version please or any 3.2 version?

Thanks for any input


Testing on W11 with 3.2.5 I cannot replicate this.

I generated a 50 minute stereo project and was able successfully rto:
a) save the project to disk
b) export a WAV file to disk

I have 120GB out of 475GB available.

Question: do you have that appropriate permissions to write to the disk from the account you are using?


Have been using audacity for 3 years on this computer and even in the hour prior on 3.2.4 successfully. All I did was allow the update to 3.2.5 to go ahead. When it started back up it appeared to be working correctly i.e. recording. A problem only came up when I tried to save the file. If I switch to other apps while Audacity is running like open notepad I can save successfully to all 3 drives… only audacity is affected.

Where can I download the audacity file to reinstall the previous version please or any 3.2 version?

[u]Older versions here[/u].

The only things I can think of…

The current version can’t save a project to a FAT32 drive. Your C-drive probably isn’t FAT32 but maybe your NAS is? (But I’m think it can export WAV to a FAT32 drive).

There is a 4GB limit for WAV files but with 50 minutes you wouldn’t be near that unless you are using crazy-high resolution. The easy fix for that is FLAC which has no “artificial” size limit, plus the files are smaller.

Or, something just got “randomly corrupted”.

The good news is… It’s an LP (not a “one time performance”) and it can be re-digitized. :stuck_out_tongue:

Thanks for thinking about it… None of time items you mention were included in the change notes from 3.2.4 to 3.2.5 so they cant suddenly become an issue in the course of a single software update to a fully working setup. I think the best path is to reinstall 3.2.4 and wait for a less buggy version to come along… or at least the bugs in 3.2.4 did not affect me :slight_smile: Things happen. Thanks again. Ed

Audacity 3.2.5 is almost identical to version 3.2.4. The only difference is this bug fix: https://github.com/audacity/audacity/issues/4373 (which looks to be irrelevant to your issue). However, Windows will see 3.2.5 as a new app, so you may need to set / reset “Permissions” for the app (as suggested by waxcylinder).

Please do let us know if reverting to Audacity 3.2.4 fixes the issue (I don’t expect that it will, but useful to know if it does).