3.2.0 Bug? Effects Disappeared from Realtime Effects - no way to rescan?

Intel machine

Downloaded/installed 3.2.0 the other day and when I first opened it, Audacity scanned my system and found VST3 and AU plug-ins.
I created a new Mono Track and activated the Realtime Effects.
Though virtually no EQ/Filters showed up, the the bulk of my AU and VST3 plug-ins appeared.
I tested Waves Clarity Vx, several Izotope plug-ins and Ozone 9 Elements, all of which worked in real time and when outputting WAV files rendered through them.

I shut down Audacity 3.2.0
(Note - I had a version 3.1.3-using audio client who had a specific question, so opened v3.1.3, confirmed issue, closed 3.1.3)

The next time I opened 3.2.0 (about an hour later), I created a new Project, activated a Mono track and opened Realtime Effects. Only about 8 plug-ins appeared - none of the ones which I had opened the first time were present.

I opened the the previously saved Project, and those plug-ins were still there, and did appear to function correctly. But even in the older Project, when I went to Add Effects using Realtime Effects, virtually none appeared.

I confirmed that all plug-ins still showed up in the EFFECTS menu.

There is no way I could find to make Audacity 3.2.0 rescan for active Effects on my system. (Something like “Rescan audio devices” would be helpful.
I was going to see if removing the config file would help.

“Rescan plugins” is in the Plugin Manager: https://manual.audacityteam.org/man/manage_effects_generators_and_analyzers.html

Ahhh… OK.
That threw me because everything was already showing up in my EFFECTS menu. Thought the rescan was just for that. Full rescan brought them in again and made them available in a new Project.

It does seem to have found more this time - the Apple AU Filters were included this time, as was the NOVA EQ from TDR. That was not the case the first time it scanned. In fact, it avoided every EQ/Filter except for Izotope Ozone 9 the first time through.

Ok. A little more info.
It seems to be related to opening 3.1.3

I opened 3.1.3 which worked fine. Imported and processed a track. Then closed that and opened 3.2.0

At that point, all floating tools had been reset to default

Upon creating a new Mono Track, none of the Effects appeared in the Realtime Effects.

That is expected, the developers did that because otherwise (especially for users with default 3.1.3 toolbar layout) the changed toolbar layout for 3.2.0 looked like an unholy mess.

So they forced a toolbars reset for the initial run of 3.2.0

See this GitHub bug entry
Toolbar layout is corrupted after an upgrade from 3.1.3 to 3.2.0 (with no reset) #2919


Not quite the point I was making.
I expected a clean tool layout (and need to resize) the first time I opened 3.2.0

But I had set things up to my preferred layout (e.g. floated meters, resized vertically), then saved and quit 3.2.0

Reopening an instance of 3.1.3 (which had maintained all of my layout changes) and quitting then 3.1.3 flushes any layout changes which I’d made to 3.2.0 (in addition to forcing a full rescan of Effects in order to use them in Realtime Effects.

If that’s by design, that’s unfortunate. I maintain different versions to assist other voice actors. It would be nice to at least have a saved layout. Maybe that’s hidden somewhere I have yet to find.

I’d recommend using a “Portable Settings” folder, so then each version of Audacity can have its own Preferences , toolbar layouts, and effect settings.
See: https://manual.audacityteam.org/man/portable_audacity.html

Thanks. I had them set up in different folders before. Got lazy back when I got rid of all the old 2.x.x versions (other than 2.4.2)
Guess I’ll go back to that.