3.0.3 experiencing extreme slowdown and is Not Responding

Mike, I had a similar issue. I have found, for me, it helps greatly to drink fluids, especially, Throat Coat Tea (Traditional Medicinals), I have learned to stay away from things that tend to dry you out. These include anything with caffeine such as coffee or tea or coke, also avoid alcohol and cough drops (except Ricola). Stay away from carbonated beverages which irritate your throat. The other thing I do is use Sinus Rinse to clear out my nasal passages which will reduce post nasal drip and the associated throat irritation.

Noel, I can see your frustration. I tried to load your .aup3 file in 3.0.4. It took 68 seconds to load on my machine. I then tried to do a save As. After 12 minutes of waiting (Not responding), I aborted Audacity 3.0.4. However, it did seem to have created a save as file. :confused:

AudacityRescue took about 2 seconds to delete 2,359,288 extraneous envelope points and to load the 54 second stereo track. Another second or 2 to do a save As. And now 3.0.4 loads the same project in only 2 seconds.

I have uploaded your “Rescued” file and PM’d you a link.

2.4M envelope points - that’s mighty impressive :astonished: :unamused: :ugeek:

Yes! And all that for a 54-second stereo track. Go figure! :confused:

Mike, I had a similar issue. I have found, for me, it helps greatly to drink fluids, especially, Throat Coat Tea (Traditional Medicinals)

thank you very much for the advice jademan, that’s a really good idea, i live in western australia (that explains my late replies due to time differece), so that product is not local to me but i found online sellers who sell them, will definetely give that a try, also thanks for all the help you gave regarding my issue. Also thanks steve for the support. I have a little suggestion, you can include a link or something either on your website or in audacity so people who would like to do a small donation to audacity can do so.

Thanks, Mike.

As Peter said,

Audacity 2.x used a multi-part project format. A project comprised of an “AUP” file and an associated “_data” folder. The folder contained the audio data, and the file contained instructions that tell Audacity what to do with the data. The “AUP” file would typically be less than 1 MB, but the _data folder could be huge (depending on how much audio data in the project).
Audacity 3.x saves projects as an “AUP3” file. The AUP3 file contains both the “instructions” and the audio data.

Ok so that explains why the file size is getting huge. but after opening my 154mb file in audacityrescue, i got a message saying “245831 envelope points have been deleted”. and the same file is now 110mb. now it is faster than before but still so laggy so i ended up making a new voice over which is so much work. worrying my new file will have the same issue later, everytime i’m done working on it, i open it in audacity rescue and everty time i get a message saying “15 envelope points have been deleted”. even if i repeat opening the file without doing any work. thought to mention it in case if that helps developing a fix.

Curious… Are you still running 3.0.4 ? Also, be sure to save the project in AudacityRescue, otherwise it does nothing.

yes, i’m running 3.0.4, because i originally created the file in the older version, 2.3.3 in 2019, it must be an aup file in the begining, and then i was working it on 3.0.0 and then on 3.0.3 and now on 3.0.4. So the aup file is now an aup3 file, may be it has something to do with that. just a thought.

Nobody wrote you can’t roll the machine back to Audacity 2.4.2. That was a perfectly serviceable Audacity version. It did use the two part Project format and it will not open aup3 files, but Audacity 3 will open up earlier projects.

Screen Shot 2021-08-26 at 8.05.30 PM.png
The main problem with the Audacity two-part project was the surprise factor. Once you know it’s going to do that, it just works.



Yep, I’m having the same ultra frustrating issue!!!
In the beginning everything seemed fine, just moving right along on project then one day…total slow down with " not responding" on literally every move I made. It’s beyond annoying

Please read this post: 3.0.3 experiencing extreme slowdown and is Not Responding - #18 by jademan

While Audacity is running slow, open task manager and try spot if some other process or background app is eating CPU cycles. Try and shut down all non-essential running programs.

I’m having a similar issue with an AUP3 file. Tasks as simple as solo-ing a track take upwards of 20 seconds.

I’ve only used like 10-16 control points maybe? I have 7 tracks on an 18 min project. Forget about opening, closing and saving… it’s unusable.

Will the Audacity Rescue program clean this up?

The literally millions of control points were inadvertently injected into projects due to a program bug.

Audacity Rescue will load projects that are not loadable by 3.0.3 or 3.0.4, if the problem is due to excessive envelope control points.

We won’t know about your project unless you try it and get back to us.

When you say loadable, do you mean that audacity will perform at normal speeds?

I am currently on version 3.0.4. I’ll download the rescue pack and see if it fixes anything.

What I was trying to point out was that I don’t use the envelope tool a lot. If the program adds its own envelope control points, then the millions of points slowing the processing down so much might make sense.

I’ll report back how it goes.

Oh and to be clear: I can load my project file, there are no error codes… it just takes a LONG time to come up.

audacity will perform at normal speeds?

No. The best we can do so far is make it less worse. This is a program bug that dates back to the fifteenth century. Most of the time patches and work-arounds are enough to keep productions going without a lot of fuss. Audacity-3 broke some of the patches and the problem can bring a show to its knees.

Jademan’s rescue program identifies most of the extra data and removes them from the show, but there can still be speed problems and nobody wrote you can’t make new damage since you’re still editing with the same program.

I don’t use the envelope tool a lot.

I questioned this earlier. I don’t think it’s an envelope tool error. The damage just shows up as a massive increase in what appears to be control points. Eventually, the machine runs out of “zot” (technical term) and slows to a crawl.

The up side is the bug is known. They’re not searching for a magic problem. The down side is fixing it without breaking anything else.


Well whatever they did helped! I can solo a track much much faster. I think what I’m going to do it render out each track individually and then reinstall the last stable version before 3.0.4. I may try 3.0.4 again just for kicks.

Thank you!

I’m glad to hear that this helped! :smiley:

There is no need to go through all of these gyrations.

No. 3.0.4 is the good and stable software, but it may not remove those extra points that were introduced erroneously by 3.0.3 and prior versions. You need to run Audacity Rescue only one time to get rid of the extra envelope points. Then stay with 3.0.4 to keep them out.