3.0.2 slow saving


I recently updated from a verison 2. Maybe someone could explain what is different about version 3? My issue is simple I think. I created a podcast using 3.0.2 about 1 hour long. had many stereo tracks… let’s say about 25… saved it as I was working… All is well.

Then I decide I want to use a number of the tracks on this as a template for another podcast… so I simply delete all the tracks I no longer need and then resave it with a different name. 5 tracks are left. What is left is about 5 minutes of introduction and then an ending about 3 minutes long… silence inbetween.

The surprise is that ver 3 takes a very long time to resave this… almost 15 minutes. What am i not understanding? Are there features that I could deselect or select to speed this up? I also tried a variation where I tried to resave a completed show under a diffent name and it too took a similiarly huge amount of time. I figured the latter would be quick as the show was already complete??

Many thanks for explaining if possible.


When you take an old 2.x project and open it up in 3.x, the entire project has to be converted from the .aup format to the .aup3 format. In this case, this could take a long time. Then when you delete a track, the UNDO information is retained as long as the project is open. When you close the project, this UNDO information is finally deleted and this can take extra time.

When you say “silence inbetween”, actual silence can take up a lot of space because each 0 must be specified.


I’ve been using Audacity on my M1 Macbook Pro 2020 since purchase with no issues until I upgraded to 3.02.

I’ve been having severe problems since upgrading to Audacity 3.02. I was using 2.4 with no problems at all. It took 5 minutes to several hours to make one change (i.e. edits, insertion, splitting, saving) - and caused significant delays for me to complete and release my podcast episode. I absolutely love Audacity and was shocked to see the changes - i.e. How slow this program became. The program eventually froze (i.e. application not responding) every time I opened it.

It was really frustrating that I couldn’t convert the AUP3 File directly back to an AUP one.

The solution was to export my current AUP3 file to an MP3 file. Then I imported this MP3 file into the older Audacity 2.4 successfully and used that to finish my editing.

I hope this post helps someone - as I lost days of my precious free time sorting this out. ANy comments or feedback would be welcome. I’m interested if any other people had this problem.

Why MP3? That’s a compressed format that will needlessly reduce the sound quality.
It’s an effective workaround, but better to export as WAV (ideally “32-bit float WAV”) rather than MP3.