22050Hz files corrupt others?

I’m currently working on layering multiple songs together, and I have 2 sets of lossless files I’m combining: .wav files encoded at 22050Hz and .flac files encoded at 44100Hz.

For some reason, whenever I import both of them into the same project, the second one I import has vastly decreased audio quality. I suspect this is tied to the aforementioned wav files, but I’m not 100% sure.

I’ve tried to do everything different, including exporting the files to check if it was just the preview, and changing the file type and stuff.

Is there any workaround I can try for now? I’d like to get this project done soon.

When importing an audio file into an empty project, Audacity takes the sample rate from the imported file as the sample rate for the entire project. Thus, if the first file that you import is one of the 22050 Hz WAVs, then Audacity will set the “Project Rate” to 22050. This will lower the sound quality of the 44100 Hz tracks.

To solve the problem, you need to manually change the Project Rate back to 44100. The Project Rate is in the bottom left corner of the main Audacity window.

I tried it, all it does is change the 22050 to sound compressed and muffled just like before…

Can someone please help me?

So are you saying that if you import the 22050 Hz WAV file into an empty project, it sounds OK, but if you import it into a project containing other tracks it sounds muffled?

Do you mean “distorted” rather than “muffled”?

I guess I mean “distorted”, but it’s more like severe compression.

And if I import it into an empty project and increase the sample rate, it has the same issue, no matter what I change it to.
Which happens automatically when I import something with a higher sample rate.

How big are these WAV files?

Ranging from 0.3 MB to 11 MB.

Could you upload the smallest one to a file sharing service such as dropbox or sendspace (ensure that it is public and does not require registration), then post exact step-by-step instructions for how I can reproduce the issue.


Just import this wav file into a new project, then change the project rate at the bottom left.

Change it to what?
If I change it to a low number (for example, 4410) then it sounds very muffled, as expected.
If I change it to a number bigger than 22050 (for example, 44100) then it sounds exactly the same as when I first imported it (also as expected).

Are you certain? I retried it once more and I’m still getting the distracting compression.
Can you try again and listen closer?

How does this version sound to you?

You’re right, it sounds untouched…
I don’t know what I have to do to achieve that result though… I literally just reinstalled Audacity days ago and didn’t mess with the settings, so that can’t help…

Try this:

  1. Import one of the 22050 Hz WAV files into a new Audacity Project.
  2. Change the Project Rate (lower left corner of the main Audacity window) to 44100
  3. Click on the track to ensure it is selected
  4. “Tracks menu > Resample”
  5. Set the “new sample rate” to 44100, and click “OK”
  6. Play the track.

How does it sound?

It worked, thank you very much!

My guess is that the problem was due to your sound card, or sound card drivers. At least you’ve got a good workaround :slight_smile: