2 second of silence


I am getting two second of silence before the recording actually starts and the red level meter shows input.
I am running Audacity 2.0.6 on a new Mac pro OSX 10.9.5 with a MOTU M8 sound card (latest software installed) connected via USB.
Here comes the strange thing. I only have the delay with USB and Audacity. When mac to sound card is connected with thunderbolt Audacity is recording right away.
When using other recording programs (garage, logic or digital performer), no two second of silence (even via USB connection). When running one if these programs in the background, Audacity also records right away.
What is that USB communication gap of two seconds in the Mac/Motu/Audacity menage a trois?

happy to read any thought

It sounds like a buffering problem. In particular, Audacity’s default buffer of 100 milliseconds currently seems too high for some modern Mac’s.

So you could go Audacity > Preferences… then look in the “Recording” section and try reducing “Audio to buffer”. Look at buffering settings in MOTU too.


Hi Gale,
thanks for the reply.
I lowered the buffer size to 50 ms but get the same two second of silence.
The MOTU manual says: ‘Under Mac OS X, audio I/O buffer size is handled by the host audio application (not by your MOTU interface’s Core Audio driver).’ So no buffer adjustment available here.
I also checked the buffer size of ‘Digital Performer’, (one of the programs that records right away). It’s set to 512. I guess they talk bits where as Audacity talks milliseconds.
I could add another observation. When going to the Mac’s ‘System preferences’ - ‘sound’ - 'input’tab, i get the same two seconds silence before any level appears.

Any other thoughts?
still confused

There isn’t anything else obvious to configure in Audacity except the buffer. Reduce the Audacity buffer as low as it will go before the sound breaks up.

What sample rate are you recording at? Try 44100 Hz or 48000 Hz bottom right of Audacity. Open /Applications/Utilities/Audio MIDI Setup and set the MOTU input to the same rate. Restart Audacity and try that.


everything is set to 44.1. Still the same result.
I have the feeling the problem is somewhere inside the Mac, that USB is not a permanent connection. Is that possible?

more ideas?

Mac’s under later OS X have aggressive power management. You could try right-click or control-click over Audacity.app > Get Info and put a checkmark (tick) in “Prevent App Nap”. But it might make no difference at all.

However you also said:

That suggests to me the problem is to do with Audacity restarting the USB audio service after the Mac turned it off. On a few MacBook Pro’s, people have said Audacity can’t restart audio playback once the Mac has turned it off - you just get a pop in Audacity until you play audio in QuickTIme.

If you run this: Antipop to keep audio services running, does it help? I don’t know if that targets USB audio, though. You may find that trying different Audio to buffer settings in Audacity could give some improvement.


i checked ‘prevent app nap’ , no difference.
we will try ‘Antipop’ on monday and let you know.


I’m running 2.0.6 on 10.10.2, an unapproved combination. I have the same symptoms as the OP when recording in via USB from a Behringer x32 console: I get a second or 2 of silence, a full-scale click only a cycle or two wide, and then everything’s fine.

This also happens when playing out from the Mac through the X_UF card into the board.

It does not happen when playing out through USB from iTunes or Qlab.

Thanks for the information.

I would guess the click is almost certainly the sound system starting.

Do any of the solutions mentioned here prevent the problem happening for you?