2.1.2 weirdness with spectral selection

I was trying to use spectral selection to filter noise. When I tried to set the upper and lower frequencies from the spectral selection toolbar, I couldn’t type in any numbers - or anything else. Pressing backspace seemed to work as “going back one character”. So, I checked the release notes…

Ah, yes, it states: "Frequency range cannot be changed in the session for scales other than “Linear”. Workaround: “Restart Audacity after changing frequency for non-linear scales.”

I’ve been trying this for more than an hour and couldn’t find any way to make that work. In fact, the behaviour is completely weird.

If I click “apply” and “OK” after changing to linear, it only seems to work on the selected parts of the track. :confused:

If I only click “OK”, nothing happens and after restarting Audacity, everything is back to default, log scale, no way to enter anything in frequencies. Other changes made don’t get saved either.

So, I created a second Audacity document, with only one track, to test, another weirdness showed up. I’d expect when saving documents, the top most window, that has mouse focus, would save in the first dialog offered, the second one in the second, and so on. Alas, no. The first save dialog is for the second window…

Any way to get this “workaround” to work? :unamused:

Works OK for me on El Capitan (though there are some bugs and weirdnesses that are logged on bugzilla, but basically it works for me)
You clearly have many settings that are non-default, so it’ll be tough to find what’s wrong or reproduce the problem.

With Audacity closed:
If you’ve got settings that you want to keep, make a backup copy of audacity.cfg and then delete audacity.cfg. (if your not bothered about saving your current preferences, just delete audacity.cfg)

Now try a simple test case - the simpler the better - and give step by step instructions for how to reproduce the issue.

You can’t type a number higher than half the sample rate of the track with the highest rate.

Minimum Frequency cannot be above Maximum Frequency.

If you want to test that, please do so in the latest alpha builds where a possible fix has been committed for the vertical scale not responding to a change in frequency range. However there are still quirks to be found and changes to frequency range don’t survive Audacity restart.

Please test that in the latest alpha build and give exact steps to reproduce the problem.

See above.

Linear is default.

Exact steps to reproduce are always good.

I see the save project dialogue appear over and relate to the window that showed the red, yellow and green window buttons before I opened the File Menu.

There is a Save Changes window switch bug http://bugzilla.audacityteam.org/show_bug.cgi?id=811.


In 2.1.2, with newly generated audacity.cfg:

  • Open Audacity
  • import audio
  • enable spectral view in left track menu
  • select “Spectral edit parametric eq” from effects menu


To use ‘Spectral effects’, enable ‘Spectral Selection’
in the track Spectrogram settings and select the
frequency range for the effect to act on.

Frequency range is at 0 to 8000 Hz, default. Changing to 100 to 4000 Hz. Same error.

  • Enable “Spectral view toolbar” from View/Toolbars menu.
  • The “frequency selection” in the Spectral view toolbar can’t be typed into. It shows “-----.-- Hz” and “–.— octave”

Latest build, 2.1.3 (audacity-nightly-2016.02.09-06.00-3f4a919) behaves exactly the same.

Suddenly, it dawned on me… :smiley:

You must FIRST select “Enable spectral selection” checkbox in “Spectrogram settings” and only AFTER that, make a selection. In this order, it functions.

If you first select part of the audio, before enabling spectral selection, it doesn’t seem to “see” the selection. No numbers appear in the toolbar. And that toolbar can’t be typed into…

And because some plugins only work on/with selected audio, I’m in the habit of selecting almost automatically after import. I didn’t even include it in the reproduction report above :blush:

So, problem solved. Not really a bug, just unexpected behaviour…

Now, back to business. Sorry for waisting your time.

Can’t do that. The option is greyed out.

I’ll assume that you mean

  1. Open Audacity
  2. Import Audio
  3. Change the track view to “Spectrogram”
  4. Enable Spectral Selection in Spectrogram Settings

The “frequency range” in the spectrogram settings is not the same as the “frequency selection” for “spectral effects”.
By default it is undefined and the Spectral Selection toolbar is hidden.

In this image from the manual, the “frequency range” of the spectrogram view is about 0 to 8 kHz. The “frequency selection” is about 2 kHz to 5 kHz.

Steve, I assume you haven’t seen my previous post, before you replied…

If there is a way to do stupid things, I’ll find it. :laughing:

Anyhow, I have today’s nightly installed, next to 2.1.2, so I’ll update that from time to time and check it thoroughly first, before reporting weirdness. :sunglasses:

I don’t like such an obscure way to turn on spectral selection, and hope it will change.

Also I don’t agree with “Spectrogram Settings…” in the track dropdown being greyed until the track is in spectrogram view. Perhaps choosing “Spectrogram Settings…” (always active) should change view to Spectrogram if the track is not already in that view.

That is not correct. You can enter frequencies into Spectral Selection Toolbar when a track is not in Spectrogram view.

If you change to Spectrogram View and turn Spectral Selection on, you will see the frequency selection in the track that you selected in the toolbar.

IMO, enabling Spectral Selection Toolbar should turn Spectral Selection on, but that should not be the required and only method to turn Spectral Selection on. There should be a switch somewhere, without wading into a dialogue to find it.


Ive probably not explained clearly. Sorry.

When you select part of the audio first and then enable spectral view, the frequency box doesn’t show any values. And the aforementioned error comes back if you try to use one of the spectral effects.

If you don’t select any audio, enable spectral view and then select audio, it works correctly.

So the only real caveat here is you shouldn’t select part of the audio before enabling spectral view…

That is correct. Spectral Selection Toolbar still shows dashes, meaning that the frequencies are undefined.

All you did is make a time selection. You have not yet selected frequencies within the time selection.

The error is correct. You have not yet selected any frequencies within the time selection.

When you drag a selection in Spectrogram view with spectral selection enabled then yes, you will drag a frequency selection as well as a time selection.

Is what you are really saying that if you go into Spectrogram view, you expect spectral selection to be already on? I have a lot of sympathy with that.

But some workflows (such as identifying clicks in LP recordings then deleting the clicks) need to be in Spectrogram view to see the clicks, but require dragging time selections without selecting frequencies. Otherwise the spectral selection “gets in the way”. Also, when more effects become aware of spectral selections it will be more important to have a way of selecting “time only” when in spectrogram view.

I like the solution of a split spectrogram/waveform view. If you select in the spectrogram area of the view, you select frequency as well as time. If you select in the waveform area, you only select time, but you can still see the spectrogram in that area.


I understand that, Gale, but if you first made a time selection, you can’t make a frequency selection, since the error reappears.

I’d expect the time selection to disappear, but it remains visible. It’s not until you deselect by clicking in the waveform, that the spectral selection appears.

And this behaviour is one-time-only. If you’ve had spectral selection working and selected some frequency band before, the error is gone, even after switching off spectral selection and back on again.

It kept confusing me, cause I tested in the same manner again and again. Maybe that’s also because the frequency selection toolbar isn’t really a toolbar?

But that’s a euhm… feature that will throw off some newbies like me, who try it for the first time, or after deleting the .cfg file.

I had played a bit with spectral selection. So, I wasn’t expecting to have to enable it in another fashion for Nyquist plugins.

Was there some change between 2.1.1 and 2.1.2? Or is it just my memory again?

Anyhow, problem solved.

And that time selection seems to persist when you switch back to waveform view. Maybe that’s part of the confusion?

If you have a time selection but no defined frequency selection, you can either:

  1. Use the “Spectral Selection Toolbar” to set the frequency selection
  2. Hover the mouse pointer near the top of the track until you find the white upward pointing triangle cursor - that’s for dragging the upper frequency bound - click and drag down. Hover the mouse pointer near the bottom of the track to find the white downward pointing triangle cursor - that’s for dragging the lower frequency bound. Click and drag up.

If you either don’t have a time selection, or don’t need to retain the current time selection, just click and drag to make a time and frequency selection (aka a “spectral selection”). Tip. click and drag across a diagonal of the rectangular region that you want to select. Only works when in a spectrogram view and spectral selection is enabled.

Spectral Selection is off by default. I would argue that is unhelpful for many people who want to use Spectrogram view. Especially when it is so hard to find where to turn Spectral Selection on.


For my money the default is set correctly with it “off”

The real problem is the hard-to-find and arcane way of turnining it on …

One solution would be to have Spectral Selection always “on” in Spectrogram views - but have that spectral selection disappear if the user switches to one of the waveform views. For me, it is a real issue that such spectral selections can continue to exist invisibly when the user switches to waveform views.


Why is it an issue, other than in waveform view you are not aware there is a spectral selection present unless Spectral Selection Toolbar is on? In that case perhaps you should support my view that there should be a small widget displaying high and low frequency when in a waveform view.

We can’t discard the spectral selection when switching out of spectrogram view. If we did that, we would not be able to sensibly store the high and low frequency of the selection in the project (look at the AUP file).


We already have a widget that displays the high and low frequency selection. It’s called the “Spectral Selection Toolbar”. If you think that looks too big and clunky, or is in the wrong place, then perhaps it needs some aesthetic refinement. I don’t see why we would need more than one widget to tell us what the frequency selection is, unless we support multiple frequency selections, which currently we don’t.

Analogy: In my car I have one speedometer which tells me the current speed of the car, but I have three mirrors (two “wing mirrors” and a “rear view” mirror). Each mirror provides a different view. Each of these “devices” are designed and positioned for convenient use whenever needed. Having two or more speedometers would be clutter and unnecessary distraction.

Apparently Peter does not want to use it though. If he did, he would know there was a spectral selection present even if in waveform view.

I argue you need “something” given Spectral Selection Toolbar is not on by default. I think it not being on by default is correct, because its presence would be very confusing if you never use spectrograms.

And yes Spectral Selection Toolbar is clunky, I think many would not want to use it given you can also use a mouse to make a spectral selection. It serves the same accessibility (and accuracy) purpose as Selection Toolbar. I don’t see it could be made smaller, unless it was just a button that opened its current interface.

I believe enabling Spectral Selection Toolbar should be one way to turn Spectral Selection on, because it is ludicrous to enter frequencies into it that have no “effect”. If so, then we can’t enable Spectral Selection Toolbar as soon as a Spectrogram track appears because turning Spectral Selection on by default seems contentious. And then we are back to square one - you cannot see the spectral selection in waveform view, because the widget I propose for waveform view is contentious.

If you have some better suggestion than a waveform display indication that there is a spectral selection, please make it. Do you need me to make a mockup image to show you what I mean?

The only other suggestion I can think of is to have an on-by-default preference for Spectral Selection Toolbar to appear when a spectrogram track is opened, or when a project is opened that contains a spectral selection. Put a checkbox in Spectral Selection Toolbar that turns Spectral Selection on (the checkbox is off-by-default). But that makes the toolbar even clunkier. I think the least visually distracting solution is the one I suggest.


I think that waxcylinder’s post sums it up nicely. Still have to read Steve and Gale’s post though :smiley:

Audacity is good, especially for beginners with moderate needs. But since it has grown naturally, the plan is missing. And those who make the features are so close to the subject, they cannot grasp the lack of understanding the beginner has.

Look at most Apple apps. To they have all the features? No, hardcore users hate these. Not “fast” enough, not enough advanced features. Beginners love 'em, because the makers do not start from the point that the user should know anything. A lot of thought has gone into really simple things, as in “In which menu should we put this feature”. The downside is that some features are left out, simply because nobody can find the right place for those…

Information being in three places isn’t good. (Not about mirrors).

As an uninformed user (read, one that doesn’t RTFM), you have to find:

  1. the left side track menu to go enable spectral view.
  2. Then, you have to select frequencies in the waveform view
  3. to have the result shown wherever the frequency display appears. Default, that is the right lower part of the interface.

1 and 2 ain’t so bad.
1, 2 and 3 is over the top.

We’re talking widgets. The uninformed user has no idea what a widget is, where it would appear, or if it’s a display only, or a control thing.

The concept “menu” is clear to almost any user. The concept “toolbar” eludes most, if there are many toolbars, looking wildly different and appearing all over the screen.

Why is the track menu (on the left of the waveform) called track menu, if there is already another track menu in the menu?