2.1.2 on 10.10.5 won't launch after upgrade [SOLVED]

Ok, it was upgrade time – a batch of 320kbps MP3’s wouldn’t batch-import reliably (later ones came in as flatline, even though they would import properly as a single file import) – and I wasn’t on the current release.

Grabbed the 2.1.2 dmg, opened it, dragged, chose Merge (which might have been a bad idea; if it matters, the background image in the DMG ought to be changed to say so), and then I went into a loop:

First time: Launches, no system errors about Gatekeeper as in my earlier posting, dies with no message.

Second time: Launches, gives a dialog box about the temp directory being locked (without saying where it thinks that is, about which I will RFE later), dies with, otherwise, no message.

If I manually remove the lock file in the tempdir, we go back to First time. :slight_smile:

I redid the drag-install, wanting to choose replace, but I didn’t get the choice. Same results.

So I renamed the folder under Applications to 2.1.0-Audacity and did what I assumed was a clean drag-install from the DMG. Still the same results.

ISTR there’s somewhere I can find out why it thinks it’s dying, but I cannot recall where that is. Can anyone tip me off?

Two clarifications:

I didn’t do the TempDir mod in the pinned post as I have it set to my own specific location in the root of a partition with enough space, and that’s where it’s been locking… hey; how’s it still know?

Does a launcher icon track the file rather than the pathname?

[ Edit: this appears a red herring; I dug to the new Apps folder and launched it directly, still dies ]

And no, I never ran it from the DMG.

Further: FWIW, I have a registered copy of Loopback installed on this machine, my MBP 7,1.

Did you have enough disk space?

“Merge” should retain any files in your existing Audacity folder that are not in the new installation and update files that are in the new installation.

Please describe what exactly happens when it dies after launching.

Meantime I suggest you force quit Audacity in Activity Monitor (if necessary). Then in Finder, use Go > Go to Folder and type in

~/Library/Application Support/

Delete the entire “audacity” folder then launch Audacity from its installation folder in /Applications.


The very initial problem was, in fact, “I’m out of room for temp files”.

RFE: “Make audacity pop up a dialog when it runs out of room to write files in the tempdir”. :slight_smile:

The later problems were exactly what it said on the tin: “click startup icon in tray, it zooms up, and then nothing else happens, and the ‘i’m running’ triangle under the tray icon disappears.”

It’s unclear what caused that; I redid the 2.1.2 install, and whacked the config file (which was ancient, dating to at least 2.0.6 and maybe earlier), and it’s behaved fine for me since.

RFE: “The dialog box saying you already have a lock file should say its full pathname.”

(There’s a separate forum group for those, isn’t there?)

Apologies for the noise; I’ve been out of the saddle at the theatre for 8 months, and my reflexes are weak. :-}

We already have a bug open for that (something we should fix):

Please clarify which dialogue this is. Is it “Audacity was not able to lock the temporary files directory”?

Or is it the “Audacity is already running” message, which does not actually mention the lock file?

Yes: Adding Features to Audacity. But there is no need to post there about the lock file message at the moment.



+1 :slight_smile:

The latter, yes, which I would contend ought to tell the user where Audacity was looking for the proof it found that Audacity was already running (which it often is not; the message might better be

Audacity has discovered its own lock file on startup in


which means that either another copy is running, or the program previously crashed without cleaning up after itself.

Also, it appears to me that if you override the lockfile, it is not removed when you clean-exit,
and hence is still there next time. That would be a design decision rather than a bug, but I myself would pick “it should be removed”.

Roj. Thanks.

As Leland said https://forum.audacityteam.org/t/cant-open-audacity-on-my-mac/37597/14 there are probably bugs in wxWidgets which prevents it removing the old lock file as it should. But you’re the first person I’ve seen so far who has had a problem with the lock file in 2.1.2. It could be that the deletion of the lock file failed because Audacity was not starting up properly, which seemed to be some separate problem.

Rather than us state the lock file location, which could encourage people to delete the file so as to run multiple Audacity instances at once, it would probably be better to make a dialogue which asked if the user wanted to restart Audacity, whereupon Audacity could try to force delete any lock file it found.

How are you choosing to override the lock file? In the dialogue “Audacity was not able to lock the temporary files directory”?