2.1.2 (from .exe) Windows 7; monitor active; does not record

First, Thank You all immensely for developing and sharing this powerful creative tool.

Bought a Dell Inspiron 15Rlast year, running windows 7, with a single jack which toggles between line in, mic, speakers, etc. (I used to be able to record the output of my cassette player just fine on an older laptop.)

Now I can see a strong incoming signal on the microphone monitors but when I press record the line is absolutely flat. I have read the Audacity manual extensively and tried every combination of settings, ‘checkings,’ and ‘uncheckings’ I could find in the laptop speaker icon right click menus; this includes making the stereo mix default as suggested, but also tried ‘line in.’ (I have default set to MME and (2) stereo, etc. but have tried to troubleshoot with every other possible combination as well.)

Nothing works. I have also tried to activate / deactivate every combination of the three recording options which appear: stereo mix, line in, and microphone. My Realtek driver is up to date. The laptop seems to have its own Microsoft sound drivers (Device Manager /System / High Definition Audio Controller) but the Realtek is the default. Could there be a conflict? Not sure what to try next.

Thank You,

Victor Jaroslaw
Brooklyn, New York


In any of those combination were you able to record the laptop built-in microphone? It would be a kick in the head to discover the laptop won’t record anything ever.

This is an extension of the “too close to the problem” problem.


That’s Microsoft hiding features again. Easily fixed. Once you’ve followed the link below, restart Audacity or click Rescan Audio Devices in the Transport menu, then after whichever you choose to do open the drop-down menu for the recording devices and
click Stereo Mix.


It’s the same in Vista. Dunno about 10.

Please tell us exactly what you are trying to record. Your singing? A song playing on the computer?

In Audacity you use Device Toolbar to choose the correct recording device (when that device is enabled in Windows Sound).

That system device should have Microsoft drivers, yes.

In Device Manager > Sound, Video and Game Controllers, does the Realtek device have Microsoft drivers? That would be incorrect. I suggest you go to http://www.dell.com/support/home/us/en/19 if you have not done so. Enter your exact computer model (or let Dell detect it) then download and install the audio driver indicated. The 15R Inspiron models I looked at are supposed to have a Conexant audio driver, not Realtek.

If your computer is supposed to have a Conexant driver, uninstall the Realtek device before installing the correct driver.


Hi Thanks to all and thanks to you too Mr. 'Koz." I am going through these trouble shooting suggestions one by one. Yes. I can record with the built in mike, but not directly from my line in, which is what I am trying to do.

Specifically, I am trying to digitize rare audio cassettes of Afro-Cuban music. I have the tape out going to my tuner and then (with the tape monitor on) the RCA out cables of my tuner going through the proper jack into that single input on my dell. I tried the suggested default (in the Audacity Manual) of MME / Realtek High Def as the input, and also set that as default in my laptop’s speaker icon to the same, under, recording, properties. To no avail! I also tried ‘line in’ as the default, also nothing. I will try some of the other suggestions, and I thank all of you for trying to help me. It is so strange that the monitors seem active but there is no recording going o nat all. You all are ‘mad cool.’ Gracias. VJ

Thank You Sir:

I visited the link but I already tried all of that multiple times with every possible configuration. My stereo mix is visible, my Realtek drivers up to date, I set it as default, checked the bit rate, levels etc… Audacity would not record. Possibly there is a clash with the built in Microsoft drivers, but the Realtek came with the laptop, was set as default, and otherwise works fine. Thank you anyway for your suggestion. I’m still baffled.

Thank you Gale:

The Realtek device has up to date Realtek drivers (I just let the laptop check on line) and the Realtek came with the laptop directly from Dell. I am not sure if there is also a Conexant Driver, installed but disabled. I a a bit frightened to uninstall the Realtek that otherwise provides me with excellent sound quality unless you excellent engineers by consensus feel that it is the source of my Audacity recording problems. I thank you highly for your input. Peace, VJ.

Thank you all:

What I am trying to do is digitize rare Afro-Cuban music from tape cassettes to Audacity.

The wiring is: tape player’s out to my tuner’s in; tuner’s ‘tape out’ (via RCA to mini) into my laptop’s single jack, which I then must set (when prompted by the laptop) to ‘line in.’ - my only input choice on the Dell laptop itself besides ‘microphone,’ once I plug in anything into the jack.)

Yes, ‘Realtek high def audio’ does show up both under sounds (in my laptop) and in Audacity’s settings menu. Also, yes, I CAN record from the built in microphone, to answer the first question. However, I can only actually record from that.

From any other input (line in or the default Realtek) I get a recording monitor signal, but no actual recording- just a perfectly flat line.

It’s baffling. I have tried every combination of settings and checked and unchecked everything under properties, tried matching the bit rates, etc., as suggested by your wonderfully explicit manual, all to no avail.

Realtek IS the default installed system that came with my Dell laptop, and I re-checked on this on Dell’s interactive trouble-shooting website as on of you suggested.

I’m stumped.

Keep trying, folks; I’ll be eternally grateful.

Many Thanks,

Victor Jaroslaw,
teacher and musician
Park Slope, Brooklyn, New York

If you want to record cassettes, the only “correct” input to choose in Audacity is Line In.

It is also possible to record with stereo mix if you can enable “Listen to this device” in Windows Sound for the Line In input.

Mic in would be the worst choice.

In Windows Sound, do you see the green meter for Line In bouncing when you play the cassette? If yes, select Line In in Audacity and record. If it looks like a flat line, Effect > Amplify… and OK. If you can now see and hear the recording then your recording level is too low. Turn up the recording slider in Audacity’s Mixer Toolbar:

Aside: If you did “Update Driver Software…” in Device Manger that is not the proper way to tell if your drivers are up-to-date, or even if they are correct for your computer. All that checks is the Microsoft database for that particular driver. The correct way is what it seems you later did, which is to go the Dell web site.

If you are still stuck, what is the exact model number of the computer? 15R-what? Also please go to Help > Audio Device Info… top right of Audacity, OK, save “deviceinfo.txt” and attach it. Please see here for how to attach files: https://forum.audacityteam.org/t/how-to-attach-files-to-forum-posts/24026/1


Dear Gale and All:

Immense thanks for getting back to me several times. I do not want to take up too much more of your individual or collective time, and I will be happy to contribute to Audacity if you tell me how. I may have a problem with my ‘combination’ (read: ‘cost-saving’) single audio jack, thanks to poor engineering on the part of Dell. If so, it will be costly to fix, as it may involve replacing the ‘motherboard.’ Just in case a work-around might exist, here are my specifics, as requested:

My laptop is a Dell Inspiron 5537, running Windows 7 Home Premium.

IMPORTANT: I realized today on doing some further engineering checks that I have NO AUDIO INPUT AT ALL, whether I choose ‘line in’ or ‘stereo mix,’ even with new RCA-to-Mini cables, and also after cleaning the RCA jacks.

The signal I THOUGHT I saw on my Audacity monitors was specious; it continued bouncing around even when I stopped the tape player, and only dropped to zero when I completely disconnected my input cable. (Noise?)

Also, in Windows Sound, there is NO BOUNCING AT ALL in the green meter line. This leads me to believe I must have either a software (driver) problem or a jack problem.

I called Dell and an engineer walked me through updating the Realtek driver:
Realtek ALC3223 High-Definition Audio Driver: (Audio_Driver_XKKPG_WN_6.0.1.7023_A00.EXE)

The install FAILED and I got this error message: “The version of this update driver is equal to the currently installed version… Realtek HD Audio Driver… Installed version : / Package version :”

So I tried my best to update my driver, if that was the source of my problems. When I restarted my computer, the Realtek reappeared, but the problem remains.

If I have a jack problem (i.e. it won’t accept or recognize an incoming signal) I guess I’ll have to deal with it. My tape player does have a USB codec output and I played around and was able to get it to record nicely in Audacity, when I change all my settings as suggested in your excellent manual. (Unfortunately, my turntable doesn’t.) This finding further leads me to suspect the fault is in Dell’s crappy combination jack.

I have attached the deviceinfo.txt below, as requested.

Many thanks to all,

deviceinfo.txt (5.77 KB)

OK then we are sure now you have the correct audio drivers for the built-in sound device.

Your Audacity audio device info does not show line in, only microphone and Stereo Mix.

I think the only way you might be able to improve things is to go into Windows Sound. Change to the “Recording” tab. Right-click anywhere inside the Recording tab and if available, choose “Show disabled devices” then right-click again and check “Show Disconnected Devices”.

What devices do you see now. Mic, Line-in and Stereo Mix?

As I said before, to record from Stereo Mix, you will need to set the Line-In to “Listen to this device”, so that it plays through the computer speakers. To do that you would right-click the Line-In, choose Properties, then click the “Listen” tab. Then restart Audacity and record from Stereo Mix.

Are you connecting the turntable directly to the computer input? If you want to record a conventional turntable it is better and simpler to attach its output to a phono amplifier then connect the amplifier to the computer. This gives you proper RIAA equalization at already amplified line level.

Does your cassette deck with USB output have a line input? If so, you could connect the turntable through a phono amplifier to the line input of the cassette deck and record from the cassette deck. Otherwise I think you may be better buying something like the Behringer UFO 202: http://wiki.audacityteam.org/wiki/Recommended_sound_devices#USB_Interfaces.


Thank you all:

I have been taking your advice and working things out. I super appreciate your time. P.S. Where can I make a small contribution to Audacity?


Let us know some details of how you fixed it, or if you need more help. Other people reading this might benefit from that.

We would appreciate a small donation if you can. Please see http://old.audacityteam.org/donate/.