2.1.0 Won't Start Correctly on Win XP SP3

I’ve been using Ver. 2.0.6 for awhile - upraded to the new 2.1.0 today. Installs OK (no errors or unexpected messages). However, the 2.1.0 application will not start correctly. Details:

When I clicked the Audacity shortcut, the Windows hourglass shows for awhile on the mouse cursor. Then it goes away and Audicity appears to not start.
However, Audacity appears in the Windows task manager, so it is running.

After about a minute passed, I used Sysinternals Filemon and Regmon to see what it was doing. Audicity was scanning my disk opening most every dll file, and maybe others. So it was active.

After another minute or so, the “Register Effects” screen appeared asking which effects to use. The list was HUGE, it looked like just about every dll on my disk. So I cleared all blocks to de-select all effects and proceeded on.

After about another minute, Audacity finally started with a normal looking screen. I tried a few simple tasks and it seemed to work OK. So I closed Audacity and then re-started it. It took about a minute to start, but no effects menu this time. I tried this several times - always the same result.

So here’s some of what I’ve tried with the end result being unsuccessful:

  • Completely un-installed Audacity, deleted the c:program filesAudacity folder
    Deleted the Audacity folder with preferences in the C:documents and settings… location.
    Re-installed Audacity 2.1.0 → same results as before.
    Re-booted the system. No change.
    Re-installed to re-set preferences. No change.
    Completely un-installed Audicity as described above, restored my previous preferences directory, and installed Ver 2.0.6:
    — The Register Effects menu (not sure if called the same) came up with a short list of dll’s that looked correct, so I selected and continued.
    — Relatively quickly, Audacity 2.0.6 started and ran fine.
    — Stopped and re-started Audacity 2.0.6 several times, very quick start-ups as before.
    Tried installing Ver 2.1.0 again → SAME STARTUP PROBLEMS AS BEFORE
    I tried disabling all the effects in the Audicity “Preferences” menu → no change.

I’ve checked my firewall and anti-virus, turned on and off. No change.
System is up to date with the latest patches that are available for Windows XP SP3.

So I’m back to version 2.0.6 for now.

Any suggestions or anybody else having the same problem?


As a follow-up to my own post, one more piece of information.

The file "C:documents and Settings…YOUR-NAME…Application DataAudacitypluginregistry.cfg is HUGE (7.7 MB). It contains entries for dll’s from about everything on my system. I went through and manually edited out everything that wasn’t flagged “the Audacity Team”. The file is now 20 kb.

I had to make sure to uncheck both the “Check for updated plugins…” and “Rescan plugins” boxes in the Audicity preferences.

Audacity now starts “normally”. However this is a hack job, but it points to something going wrong with what Audacity puts into the new (for 2.1.0) pluginregistry.cfg file.

When you first launch Audacity, or if you rescan for new plugins, Audacity searches several specified locations.
On Windows these are:

  • The Audacity plug-ins folder in the location Audacity is run from:
  • the “Plug-Ins” folder in the directory where Audacity resides - usually C:Program Files or C:Program Files (x86)
  • Documents and SettingsApplication DataAudacityPlugins
  • C:Program FilesSteinbergVSTPlugins (or C:Program Files (x86)SteinbergVSTPlugins on 64-bit systems).
  • Windows Registry key HKCUSoftwareVSTVSTPluginsPath
  • Windows Registry key HKLMSoftwareVSTVSTPluginsPath
  • All paths specified by the “VST_PATH” environment variable.

From your description it sounds like you have some incorrect paths set up on your machine, causing Audacity to search in many more locations than it should be looking.

If you feel confident about searching the Windows registry, I’d suggest that you check those registry keys to see what paths are listed there. WARNING: changing registry settings can cause your computer to not boot up - if you are not confident about browsing the registry, don’t do it.

Steve, you’re the man!

From one of your suggestions: “Windows Registry key HKLMSoftwareVSTVSTPluginsPath”
This was the one. The entry existed as a string value under HKLMSoftwareVST, however value was not set (it was empty).

So for now I just set it to an empty “junk” directory I keep on my system. I re-started Audacity with both boxes set to re-scan for plugins, it found just a few (instead of a thousand) and all is fine!

Looks like Audacity was treating the blank value as .

(There still may be a problem on my system where the entry should have some value and got corrupted, but that’s my problem to solve.)

Many thanks!