2.0.6 crashes, freezes computer on launch

Hello all,

First of all thanks in advance for any and all help and advice.

I am using Audacity 2.0.6 on Windows 7, Service Pack One.

When I launch Audacity, the computer freezes before launch is complete. I have tried resetting my preferences by editing the file as instructed in the manual, but with very limited success. Often, when I open this file, the text consists of nothing but a long string of spaces. I have also tried reinstalling Audacity, but with no change in the problem.

I can sometimes get Audacity to launch by plugging in a pair of USB headphones to one particular port, but it does not launch every time this is done. When it does launch successfully, changing the recording device in the preferences or by using the device toolbar causes it to freeze.

I would be very grateful for any assistance.

While Audacity has no direct connections to the computer, it uses Windows device drivers and they do. So Audacity launches and gets as far as trying to address your sound devices, hits bad driver software and blammo.

That probably explains why, when you change the sound device externally with your USB headset, the system gets further along. Windows naturally assumes when you plug a USB sound device in that you want to use it immediately, so ignores what may be other damaged software.

Make sure your computer drivers and support software are undamaged and up to date.

Reinstalling Audacity doesn’t reset it. To reset it, run the install and click the place it says to reset preferences.


Thanks for getting back to me so fast!

Sorry, I should have mentioned I’d done exactly that.

Done. I used Windows’ “Update device drivers”. It looks like the drivers for my sound devices (ATI HDMI Audio and Realtek High Definition Audio) are intact and up-to-date. Unfortunately, the problem persists.

Unfortunately that will usually not give you the most up to date drivers for your sound card. It only checks generic Windows drivers, not the specific drivers for your actual hardware.

I think there is a good chance that the problem is caused by a driver issue.
See this article: Missing features - Audacity Support

Thanks very much! I really appreciate the clear, helpful tone and concise information–which, looking around, appears to be the norm here. Updating my drivers by going to the manufacturer’s site appears to have done the trick.

I think Windows Device Manager is a little more intelligent than that (but not much). It should I believe find WHQL certified third-party drivers, and “sometimes” Windows Update will offer updated drivers that have passed WHQL.


Yes, I’ve read that it should be able to do that, but during the many years that I used Windows I never saw it actually do that, just like I’ve never seen the Windows “trouble shooter” come up with an actual solution. I’m not saying that it never happens :wink: