2.0.3 crashes on startup. Fixes don't work[SOLVED]

Hi,

Ever since I installed Audacity 2.0.3, it crashes on startup. I have combed through the forums. I have tried:

-restarting
-repairing permissions
-deleting all new plugins (LADSPA, SWH)
-reinstalling
-creating an application support document to disable plugins
-removing any plugin that has the word “wave” in it
-re-downloading the zip and disk image files and installing those…

I have not tried downgrading to an earlier release.

version 1.2.6 worked fine, but I hesitate to regress since I can find nothing in any documentation that says my mac won’t support this version…

Model: PowerBook5,6, BootROM 4.9.1f1, 1 processor, PowerPC G4 (1.2), 1.5 GHz, 1 GB
Mac OSX 10.5.8

…however, I DID just have to downgrade to an earlier version of QuickTime (7.3.1 for Tiger) since the newer version was mismatched to my old version of iMovie. Could that be a problem?

I really, really need to be able to clean out more white noise from recordings without altering the basic voices on the recordings. I am hoping this release may improve that.

Thanks, and if I missed this issue somewhere in the forums, I apologize in advance for being redundant.

Cam

This is the first few lines of the report. The rest is attached:

Process: Audacity [267]
Path: /Applications/Audacity/Audacity.app/Contents/MacOS/Audacity
Identifier: net.sourceforge.audacity
Version: 2.0.3.0 (2.0.3.0)
Code Type: PPC (Native)
Parent Process: sh [265]

Interval Since Last Report: 1772 sec
Crashes Since Last Report: 1
Per-App Interval Since Last Report: 30 sec
Per-App Crashes Since Last Report: 1

Date/Time: 2013-07-29 13:20:01.391 -0400
OS Version: Mac OS X 10.5.8 (9L31a)
Report Version: 6
Anonymous UUID: 0C44BD5D-80D9-44CB-B63E-5A6827495C3A

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x00000000fffffefc
Crashed Thread: 0

Thread 0 Crashed:
0 Audacity 0x00556c3c wxMBConv::cMB2WC(char const*, unsigned long, unsigned long*) const + 124
1 Audacity 0x0007d74c LoadAudioUnitsOfType(unsigned long) + 156
2 Audacity 0x0007d8e0 LoadAudioUnits() + 24
3 Audacity 0x000b6bc4 LoadEffects() + 2076
4 Audacity 0x00041d34 AudacityApp::OnInit() + 2824
5 Audacity 0x0053e11c wxEntry(int&, wchar_t**) + 140
6 Audacity 0x0003c554 main + 20
7 Audacity 0x0003bf7c _start + 756
8 Audacity 0x0003bc80 start + 44
ProblemReport_Audacity.txt (29 KB)

You have several very serious problems:

The cross of PowerPC and OS-X 10.5.8 may have been convenient, but Final Cut (for one prominent example) will not cross the PowerPC/Intel boundary no matter which OS you use. I think QuickTime Services (as you point out) have trouble with that combination as well. The corporate Video Conferencing service will not run on PowerPC and we reluctantly killed off many PowerPC machines because of many other crossing problems.

I don’t remember what the official party line is, but I suspect newer Audacity is not stable on that combination.

~~

You used two “kiss of death” phrases in the same sentence: “Clean Up” and “White Noise.” You can’t take white noise out of voices. Noise Removal works by generating a “profile” or sampling of the evil noise and then later, tries to remove that profile from the show. This works pretty well with fan, low background, computer whine, or air conditioning noises, but white noise has energy at all frequencies, so Noise Removal obediently tries to remove all frequencies from the show. In other words, everything. Usually, the best you can do is bubbling, cell phone voices.

There is a provision to exclude voices from the noise removal process, but this gives you a velvety, quiet show with hissy, snake voices.

So it may be just as well you couldn’t get Audacity to run…

Koz

There is no official line that says that. We explicitly patch Audacity for OS X 10.5.8 PPC for a problem where a first-time installation of Audacity would hang on launch if VST effects were detected.

Audacity 1.2.6 would be assumed less suitable than 2.0.3 for OS X 10.5.8, because 1.2 is not properly Tiger aware.

The crash report cites Audio Units, so I can only assume Audacity is calling com.apple.audio.units.Components 1.3.4 (1.3.4) /System/Library/Components/CoreAudio.component/Contents/MacOS/CoreAudio .

Make sure you are following http://wiki.audacityteam.org/wiki/User:BillWharrie/Resetting_Preferences_on_Mac , that you force quit Audacity (COMMAND - Option - Escape) then disable Audio Units in audacity.cfg by removing all the text except the following:

NewPrefsInitialized=1
[AudioUnits]
Enable=0
GUI=0

All noise removers that filter noise have the same ultimate limitation that Koz noted to a greater or lesser extent. But you may not have “white noise” in the sense that it is in all frequencies. You would have to look at Analyze > Plot Spectrum to check that, if you get Audacity to launch.


Gale

There are ways to improve on the default behaviour, but probably best to deal with the crashing issue first, so Cammie, once the crashing issue is resolved, if you are not satisfied with the results that you get from Noise Removal, please start a new topic about that and we’ll see what we can do to help you optimise the Noise Removal settings.

Okay, everybody…

It finally is working!

I see where I made the mistake.
When I created/altered the audacity.cfg file, I didn’t do it at my home location but at HD/Library.

As for the white noise… I just didn’t want to have the track to revert to robot voices. But I will browse the other threads for fine tuning on that topic.

Many many thanks to you all! You’ve restored my sanity for a further 10 minutes! :wink: