2.0.1 freezing

For the past few days I have been toticing that 2.0.1 is freezing when I am trying to edit a file (FLAC). The FLAC files resides on my internal drive. What can be causing this? I The temp file /home/randy/ is saved to my internal drive which has just over 120GB of free space.

I am running Linux Mint XFCE 14 on a HP laptop Pavillion dv6. Any ideas what I should do? Any other things I should check? I have 3GB of RAM as well. I always have to recover the file after the freeze and resume what I was doing.

Is the problem with that particular FLAC file? Is that FLAC file in a saved project (AUP)?

Generate a tone and export as FLAC. Import the FLAC file. Make the same edits as with the FLAC file that freezes. Does that freeze?

If the problem with the particular project or FLAC file persists, you could try File > Open Metadata Editor then press “Clear”.

Also look at how you are importing the FLAC file. It defaults to importing with libsndfile but you can try File > Import > Audio then select FLAC files in the list of types. This should make the file import with libflac instead of libsndfile.

Please note that 2.0.1 is obsolete - does this mean you are using the Linux Mint packaged version of Audacity? I recall Linux Mint packaged versions can freeze when importing files, or nothing happens when you import. It could be some library conflict. Uninstalling the packaged version and building Audacity from HEAD (currently 2.0.4 alpha) might - or might not - help.


What is HEAD?

“HEAD” is the current Audacity source code which you can compile. See here http://wiki.audacityteam.org/wiki/CompilingAudacityForBeginners#simple for instructions. You may find that sudo apt-get build-dep audacity doesn’t get all the Audacity dependencies, leading you to have to manually install the -dev packages of missing libraries. I found that the last time I tried to build Audacity on Linux Mint (a year or more ago).

You can also build Audacity from the source tarball http://audacityteam.org/download/source but may similarly have to install extra libraries.

Did you try any of my suggestions?


Hi Gale

I installed the ppa for Audacity so now i have 2.0.4 and so far seems to work fine.

I use the import feature all the time to bring all of my files into Audacity.

I will post back if I run into any problems but so far everything looks fine. Thanks for your suggestions, they really helped me understand better how I use files in Audacity.