16 bit width reduction when Batch processing wav files

Hi, I just found out if batch processing 48/24 WAV uncompressed files in getting rid of silences, which works fine by the way, the saved file as a result of -Export as WAV- is set to 48/16. Having my pref. settings set to 48/32 (because -Export as wav- dos not have 24 setting) I wonder where the program get’s it’s settings from whilst batch processing? And is it possible to add a parameter to the Export as WAV command to set sample and width rate. Thnx’s

You may be pleased to know that for the upcoming 2.3.0 we have added a direct option in the Export as WAV enabling you to directly select 24-bit WAV export from the dropdown.

In 2…2.2 current release and earlier that ability to do this is available - but it is a little “hidden”.

  1. choose File > Export > Export Audio
  2. in the Save as Type dropdown choose Other uncompressed files
  3. in the extra box that pops up ensure that the Header is set to Wav
  4. i#then in the Encoding dropdown, choose Signed 24-bit PCM

So you may see why we decided to make it a bit easier for the next release :wink:

You can’t use Chains to batch process this as there is no “Export Audio” command available for Chians.

In 2.3.0 Chains are replace by Macros (and much improved) - and with the addition of the direct 24-bit setting for “Export as WAV” you will be able to make that setting and then Audacity wlil “remember” that setting and use it for your next uses of “Export as WAV” (including in Macros) until you change it for something else.

If you want to try an alpha build of 2.3.0 (reasonably stable - I use it a lot as a QA tester) I can supply you with a link for a download of an alph and a link to the alpha Manual pages about Macros.