Keyboard shortcut interference

This section is now closed.

Audacity 1.2.x is now obsolete. Please use the current Audacity 2.0.x version.

Keyboard shortcut interference

Permanent link to this post Posted by bayoujay » Wed Jan 23, 2008 7:53 pm

I'm using Audacity 1.2.5 on my MacBook and when I save and try to type in the file name, it automatically activates the keyboard shortcuts. (When I press keys that happen to be shortcut keys.) This causes unintended things to occur, such as playing, pausing, etc. during the saving process. I tried to disable the keyboard shortcuts, but could not find such a disable option. Any idea what's going on and how I can stop it?
bayoujay
 
Posts: 2
Joined: Wed Jan 23, 2008 7:45 pm

Re: Keyboard shortcut interference

Permanent link to this post Posted by alatham » Thu Jan 24, 2008 9:46 pm

I've never seen anyone with this problem.

The only thing close is that it's impossible to type 'z' into the name of a marker within an Audacity project. I've never seen anyone saying that shortcuts are interfering with saving. Madness.

The only thing I can think of is to change all the overlapping keyboard shortcuts to something less common. For instance, change 'r' (for Record) to [shift]+r.
alatham
Forum Staff
 
Posts: 1594
Joined: Tue Jul 31, 2007 2:27 pm
Location: Chicago, IL

Re: Keyboard shortcut interference

Permanent link to this post Posted by bayoujay » Fri Feb 08, 2008 6:08 pm

Thanks Alatham,
I assure you that it was happening, so I've taken your advice to change the shortcuts with simple letters like "A" to "Shift+A". That should solve the problem. If not, I'll be posting again.
bayoujay
 
Posts: 2
Joined: Wed Jan 23, 2008 7:45 pm

Re: Keyboard shortcut interference

Permanent link to this post Posted by jessw » Fri Feb 22, 2008 2:06 am

This exact same thing just happened to me! When I try to save a file with an "r" in the title, it starts recording a new track! Annoying.
jessw
 
Posts: 1
Joined: Fri Feb 22, 2008 2:04 am

Re: Keyboard shortcut interference

Permanent link to this post Posted by sephethus » Sat Apr 12, 2008 7:56 pm

I have the same exact problem, quite annoying. Will this be fixed along with the USB microphone issues?
sephethus
 
Posts: 2
Joined: Sun Apr 06, 2008 6:49 pm

Re: Keyboard shortcut interference

Permanent link to this post Posted by phosphorous » Tue Dec 02, 2008 4:48 am

Yup. I have the same problem, No problem on Mac OS 10.3, but on 10.5.5 the keyboard shortcuts get in the way of saving, and can't be disabled in preferences? Any suggestions. Apart from going back to 10.3.

Thanks P
phosphorous
 
Posts: 1
Joined: Tue Dec 02, 2008 4:32 am

Re: Keyboard shortcut interference

Permanent link to this post Posted by kozikowski » Tue Dec 02, 2008 4:55 am

The Mac people can close Audacity and trash their Audacity Preference File (audacity.cfg). Audacity will start over at the next launch at First Birthday with all the key dependencies hopefully gone. It's worked before.

Of course, all your preferences will be gone, too, so you''ll have to go back in and set up your lame, stereo, MP3 rate, etc. etc.

Koz
kozikowski
Forum Staff
 
Posts: 25801
Joined: Thu Aug 02, 2007 5:57 pm
Location: Los Angeles

Re: Keyboard shortcut interference

Permanent link to this post Posted by kozikowski » Tue Dec 02, 2008 4:59 am

<<<Will this be fixed along with the USB microphone issues?>>>

I didn't have any USB microphone issues...

USB Microphone
http://kozco.com/tech/audacity/USB_Microphone.html

...which ones did you have?

Koz
kozikowski
Forum Staff
 
Posts: 25801
Joined: Thu Aug 02, 2007 5:57 pm
Location: Los Angeles

Re: Keyboard shortcut interference

Permanent link to this post Posted by buckbucknumber3 » Sun Feb 14, 2010 5:07 am

Not "madness" at all. I am having this exact same problem. I try to type in a file name in the save dialog and keyboard shortcuts start firing off based on what letters happen to me in my desired filename. Very irritating and potentially could screw up my work. I am using 1.2.5 on a Macbook running OS 10.5.8(Leopard). I guess i can do the work around of reassigning all the shortcuts, but this is a poor fix for something that should never occur.

additional info that has a remote possibility of being involved with the problem: I have a Wacom Intuous 2 tablet attached to the Macbook.

otherwise, GREAT GREAT software!!!!!!

thanks for any help.
buckbucknumber3
 
Posts: 2
Joined: Sun Feb 14, 2010 4:13 am

Re: Keyboard shortcut interference

Permanent link to this post Posted by kozikowski » Sun Feb 14, 2010 7:17 am

Since this bubbled up again, you need to know that if you're on an Intel Mac (Apple > About This Mac) under Leopard or Snow Leopard (10.5 or 10.6), your machine does not support Audacity 1.2. Upgrade to Audacity 1.3.11.

Intel Mac people still running Tiger (10.4) are fine with Audacity 1.2.5, but I would certainly upgrade anyway, or install both. You can do that safely as long as you never try to use them both at the same time. Audacity 1.3 Projects will not open in 1.2.

Koz
kozikowski
Forum Staff
 
Posts: 25801
Joined: Thu Aug 02, 2007 5:57 pm
Location: Los Angeles

Next

Return to General Feedback and Discussion



Who is online

Users browsing this forum: No registered users and 0 guests