"Détacher aux silences" ne fonctionne plus (résolu)

Poser les questions en français

ImageMerci de noter que la plupart des membres de l'assistance d'Audacity ne parlent qu'anglais. Par conséquent, nous ne pouvons garantir une réponse aux questions en français.

Si vous n'avez pas reçu de réponse et que vous pouvez parler anglais, merci de vous adresser au Forum anglais dans la section appropriée à votre système d'exploitation et à votre version d'Audacity.

"Détacher aux silences" ne fonctionne plus (résolu)

Permanent link to this post Posted by cg37 » Sat Nov 25, 2017 4:28 pm

Bonjour.
Dans le menu "Edition" la commande "Délimitations du clip" \ "Détacher aux silences" ne fonctionne plus.
Comment le faire fonctionner à nouveau ?
Système Windows 10
Audacity version 2.2.0

Merci.
Last edited by cg37 on Fri Dec 01, 2017 3:56 pm, edited 1 time in total.
cg37
 
Posts: 29
Joined: Sat Nov 28, 2009 10:40 pm
Operating System: Please select

Re: "Détacher aux silences" ne fonctionne plus

Permanent link to this post Posted by Trebor » Sat Nov 25, 2017 6:49 pm

Audacity 2-2-0, Détacher aux silences.gif
Audacity 2-2-0, Détacher aux silences.gif (131.38 KiB) Viewed 217 times
Trebor
 
Posts: 4027
Joined: Sat Dec 27, 2008 5:22 pm
Operating System: Windows Vista

Re: "Détacher aux silences" ne fonctionne plus

Permanent link to this post Posted by cg37 » Sun Nov 26, 2017 7:44 am

C'est justement ce que vous montrez qui ne fonctionne plus chez moi.
Sinon je connais très bien ce que vous me montrez, là n'est pas le problème.
cg37
 
Posts: 29
Joined: Sat Nov 28, 2009 10:40 pm
Operating System: Please select

Re: "Détacher aux silences" ne fonctionne plus

Permanent link to this post Posted by Trebor » Sun Nov 26, 2017 3:24 pm

cg37 wrote:C'est justement ce que vous montrez qui ne fonctionne plus chez moi.

"Détacher aux silences" ne fonctionne que s'il y a un vrai silence de ligne plate.
S'il y a un bruit de bas niveau constant à travers la piste, le "détacher aux silences" ne fonctionnera pas.
Si c'est le problème, vous pouvez utiliser une porte de bruit pour transformer le bruit de bas niveau en silence de ligne plate, donc "détacher aux silences" fonctionnera.

porte de bruit plugin ici ... http://wiki.audacityteam.org/wiki/Nyqui ... Noise_Gate
Trebor
 
Posts: 4027
Joined: Sat Dec 27, 2008 5:22 pm
Operating System: Windows Vista

Re: "Détacher aux silences" ne fonctionne plus

Permanent link to this post Posted by cg37 » Sun Nov 26, 2017 4:20 pm

Merci mais,
qu'est-ce qu'une porte de bruit ? (désolé, je ne suis qu'un utilisateur occasionnel d'Audacity).
J'ai pensé à ce que vous me dites, aussi j'ai essayé avec un enregistrement ancien où cela fonctionnait et résultat, j'ai le problème.
C'est pour ça que j'ai écrit "Détacher aux silences ne fonctionne plus" et non "ne fonctionne pas"
Ça a fonctionné quelque temps avec la v.2.2.0 et bien-sûr avec la version précédente.
A la première commande "Détacher aux silences" il affiche:

Capture1.JPG
A la 1ère commande
Capture1.JPG (45.67 KiB) Viewed 192 times


OK je sélectionne tout (ce qui n'était pas nécessaire auparavant, mais passons...) et quand je redemande à nouveau "Détacher aux silences" soit rien ne se passe, soit il affiche:

Capture2.JPG
A la 2ème fois
Capture2.JPG (48.24 KiB) Viewed 192 times


Il s'agit là d'un enregistrement (depuis Deezer) qui fonctionnait très bien il y a une semaine ou deux.
Mystère et boule de gomme...!!!
cg37
 
Posts: 29
Joined: Sat Nov 28, 2009 10:40 pm
Operating System: Please select

Re: "Détacher aux silences" ne fonctionne plus

Permanent link to this post Posted by cg37 » Sun Nov 26, 2017 5:05 pm

Nouveaux essais:
Sur le poste de mon épouse (que j'appellerai PC n°2 et mon poste, PC n°1) tout fonctionne bien, avec la même configuration: W10 et Audacity 2.2.0.

Par contre:
Si je transfère un enregistrement fait avec PC n°2 sur PC n°1 (via une clé USB) Audacity sur PC n°1 détache bien les silences. (parfait !)
A l'inverse:
Si je transfère le même enregistrement, mais fait avec PC n°1, sur PC n°2 (toujours via une clé USB) Audacity sur PC n°2 ne détache pas les silences.

Le problème est donc dans l'enregistrement sur le PC n°1, qui ne se déroule pas comme il faudrait, non ??

Autre différence entre les deux postes:
Sur le PC n°2, au bout de 10'' de silence, l'enregistrement s'arrête automatiquement. (c'est bien pratique)
Sur le PC n°1, rien de tel, Audacity continue à enregistrer (du silence bien-sûr) et ce pendant des heures et des heures si je ne l'arrête pas.
Je n'ai jamais réussi à trouver pourquoi. Ce problème était déjà là dans la version précédente.
cg37
 
Posts: 29
Joined: Sat Nov 28, 2009 10:40 pm
Operating System: Please select

Re: "Détacher aux silences" ne fonctionne plus

Permanent link to this post Posted by Trebor » Sun Nov 26, 2017 5:35 pm

cg37 wrote:Merci mais,
qu'est-ce qu'une porte de bruit ?

C'est un outil pour écraser tous les sons en dessous d'un seuil jusqu'à un vrai silence plat.
Audacity ne vient pas avec un porte de bruit: vous devez installer un plugin.

la région # 1 n'est peut-être pas vraiment un silence plat, il faut zoomer pour vérifier.png
la région # 1 n'est peut-être pas vraiment un silence plat, il faut zoomer pour vérifier.png (63.61 KiB) Viewed 188 times

vertical zoom.gif
zoom avant révèle que ce n'est pas le vrai silence de la ligne plate
vertical zoom.gif (156.13 KiB) Viewed 188 times
https://manual.audacityteam.org/man/zoom_tool.html
Trebor
 
Posts: 4027
Joined: Sat Dec 27, 2008 5:22 pm
Operating System: Windows Vista

Re: "Détacher aux silences" ne fonctionne plus

Permanent link to this post Posted by cg37 » Sun Nov 26, 2017 5:57 pm

Mais pourquoi le PC n°2 trouve des silences que le PC n°1 ne trouve pas, à partir du même enregistrement ?
Il y a un passage de silence ou il n'y en a pas. Le même passage ne devrait pas être traité différemment d'un PC à un autre, non ?
cg37
 
Posts: 29
Joined: Sat Nov 28, 2009 10:40 pm
Operating System: Please select

Re: "Détacher aux silences" ne fonctionne plus

Permanent link to this post Posted by Trebor » Sun Nov 26, 2017 6:41 pm

Si ce sont exactement les mêmes enregistrements, ils doivent être traités de la même manière.
Il y a quelque chose appelé dither noise, qui est un bruit très faible, qu'Audacity ajoute par défaut quand vous créez un fichier audio.
le bruit de vibration remplacerait tout silence de ligne plate par un faible bruit et empêcherait le "Détacher aux silences" de fonctionner.
La copie sauvegardée (avec ajout de bruit) n'est pas exactement la même.

Le bruit de Dither peut être désactivé dans les préférences Audacity ...
http://manual.audacityteam.org/man/quality_preferences.html
Trebor
 
Posts: 4027
Joined: Sat Dec 27, 2008 5:22 pm
Operating System: Windows Vista

Re: "Détacher aux silences" ne fonctionne plus

Permanent link to this post Posted by cg37 » Sun Nov 26, 2017 8:05 pm

Oui oui oui, ce sont exactement les mêmes enregistrements. C'est le même morceau pris sur Deezer mais enregistré sur 2 PC différents.
Les 2 PC ont la même configuration dans les préférences notamment "Deather noise" Lissage en français !
C'est à l'enregistrement que le PC n°1 enregistre un son (aussi minime soit-il) là où il y a un silence pour le PC n°2. C'est là qu'est le problème, j'en à peu près certain.

(Shaped équivaut à quoi en français ? Onde ?)
cg37
 
Posts: 29
Joined: Sat Nov 28, 2009 10:40 pm
Operating System: Please select

Next

Return to Français



Who is online

Users browsing this forum: Google [Bot] and 1 guest