visual interface unusable

Help for Audacity 2.x.x on GNU/Linux.

ImageThis forum is for Audacity 2.x.x on GNU/Linux.
Please state:
  • which version of Linux you are using,
  • the exact three-section version number of Audacity from Help menu > About Audacity,
  • whether you installed your distribution's release, PPA version, or compiled Audacity from source code.

Audacity 1.2.x and 1.3.x are obsolete and no longer supported. If you still have those versions, please upgrade (see https://www.audacityteam.org/download/).
The old forums for those versions are now closed, but you can still read the archives of the 1.2.x and 1.3.x forums.

visual interface unusable

Permanent link to this post Posted by rmlrml » Thu Jan 11, 2018 5:28 am

Debian sid
Audacity 2.2.1, distribution's release

Problem with the visual interface since the last couple months. Audacity used to follow my system's dark GTK theme, but now it seems to be sort of mixed dark and light, kind of ugly but whatever. Looking at the history I'd say it's been since the 2.2.* branch. I just haven't really been bothered by it enough until now to ask for help.

Now when I tried to adjust the spectrogram settings, the dialog box is light grey text on white background making it unusable. Changing the theme in Preferences doesn't make a difference, it's the same with all of them. I'm including screenshots with the light theme and dark theme applied and the spectrogram settings dialog box up.

audacity screenshot with light theme applied, spectrogram settings box
2018-01-11-000219_1920x1080_scrot.png
audacity screenshot with light theme applied, spectrogram settings box
2018-01-11-000219_1920x1080_scrot.png (988.93 KiB) Viewed 169 times


audacity screenshot with dark theme applied, spectrogram settings box
2018-01-11-000529_1920x1080_scrot.png
audacity screenshot with dark theme applied, spectrogram settings box
2018-01-11-000529_1920x1080_scrot.png (998.04 KiB) Viewed 169 times
rmlrml
 
Posts: 4
Joined: Thu Jan 11, 2018 5:13 am
Operating System: Linux Debian

Re: visual interface unusable

Permanent link to this post Posted by steve » Thu Jan 11, 2018 9:06 am

I don't have Sid installed so I can't make specific suggestions, but you could try tweaking the Interface / Theme settings in Audacity to suit your Desktop theme settings: http://manual.audacityteam.org/man/inte ... ences.html
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 45650
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: visual interface unusable

Permanent link to this post Posted by rmlrml » Thu Jan 11, 2018 2:14 pm

@steve as I said, changing the theme in Preferences > Interface doesn't make a difference, unless you meant something else. I don't see any other relevant options in the Interface settings.
rmlrml
 
Posts: 4
Joined: Thu Jan 11, 2018 5:13 am
Operating System: Linux Debian

Re: visual interface unusable

Permanent link to this post Posted by rmlrml » Thu Jan 11, 2018 2:47 pm

Update: also tried changing the system gtk theme to a few different ones, didn't make a difference. Audacity's menus conform to the theme, but the spectrogram settings box is still all white with light grey text.
rmlrml
 
Posts: 4
Joined: Thu Jan 11, 2018 5:13 am
Operating System: Linux Debian

Re: visual interface unusable

Permanent link to this post Posted by steve » Thu Jan 11, 2018 3:32 pm

Have you tried the "Blend system and Audacity theme" setting?
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 45650
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: visual interface unusable

Permanent link to this post Posted by rmlrml » Thu Jan 11, 2018 4:58 pm

Yeah, it was already checked. Out of curiosity I unchecked it and restarted Audacity, didn't make a difference.

Does Audacity use gtk2 or gtk3? My system seems to be using a hybrid of both. Maybe I don't have the right gtk-related package installed.
rmlrml
 
Posts: 4
Joined: Thu Jan 11, 2018 5:13 am
Operating System: Linux Debian

Re: visual interface unusable

Permanent link to this post Posted by steve » Thu Jan 11, 2018 5:04 pm

rmlrml wrote:Does Audacity use gtk2 or gtk3?

Gtk2.

rmlrml wrote:Maybe I don't have the right gtk-related package installed.

That should be all sorted out for you by the person that packaged it.
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 45650
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu


Return to GNU/Linux



Who is online

Users browsing this forum: No registered users and 2 guests