I'm getting "The system has detected that another copy of Au

Help for Audacity 2.x.x on GNU/Linux.

ImageThis forum is for Audacity 2.x.x on GNU/Linux and Unix-like operating systems.
Please state which version of Linux you are using, the exact three-section version number of Audacity from Help > About Audacity... and whether you installed your distribution's release or daily version of Audacity or compiled Audacity from source code.

Audacity 1.2.x and 1.3.x are obsolete and no longer supported. If you still have those versions, please upgrade at https://www.audacityteam.org/download/.
The old forums for those versions are now closed, but you can still read the archives of the 1.2.x and 1.3.x forums.

I'm getting "The system has detected that another copy of Au

Permanent link to this post Posted by squatcobbler » Thu Aug 24, 2017 11:55 pm

I'm getting:

"The system has detected that another copy of Audacity is running."

I'm on Ubuntu 16.04. (Unity) I don't know what version of Audacity (well hell, I can't run it to find out from the About menu!) But it's whatever version was around that time- so about six months ago...

So I guess this counts as a bug report....

Soooo... I'm trying to think of what else to provide. It's a desktop machine, Lenovo.

Anyway, btw I'm a programmer for 20 years, so whatever you want, lemme know, thanks.
squatcobbler
 
Posts: 2
Joined: Thu Aug 24, 2017 6:15 pm
Operating System: Linux *buntu

Re: I'm getting "The system has detected that another copy o

Permanent link to this post Posted by steve » Fri Aug 25, 2017 1:43 am

There's probably a left-over lock file stopping Audacity from launching.
Ensure that Audacity is not running at all, then look in /var/tmp/audacity-<your-user-name>/
That folder should be empty when Audacity is not running.
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 44466
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: I'm getting "The system has detected that another copy o

Permanent link to this post Posted by squatcobbler » Fri Aug 25, 2017 8:08 am

Thanks steve, you nailed. Just a matter of rm -rf * and it worked,

thanks again,

-sc
squatcobbler
 
Posts: 2
Joined: Thu Aug 24, 2017 6:15 pm
Operating System: Linux *buntu

Re: I'm getting "The system has detected that another copy o

Permanent link to this post Posted by steve » Fri Aug 25, 2017 8:12 am

squatcobbler wrote:Thanks steve, you nailed. Just a matter of rm -rf * and it worked,

Excellent :)

squatcobbler wrote: btw I'm a programmer for 20 years,

Ooh that's interesting ;) ... have you ever considered contributing to open source software? :mrgreen:
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 44466
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu


Return to GNU/Linux and Unix-like



Who is online

Users browsing this forum: No registered users and 5 guests