need speed

Help for Audacity 2.x.x on GNU/Linux.

ImageThis forum is for Audacity 2.x.x on GNU/Linux and Unix-like operating systems.
Please state which version of Linux you are using, the exact three-section version number of Audacity from Help > About Audacity... and whether you installed your distribution's release or daily version of Audacity or compiled Audacity from source code.

Audacity 1.2.x and 1.3.x are obsolete and no longer supported. If you still have those versions, please upgrade at https://www.audacityteam.org/download/.
The old forums for those versions are now closed, but you can still read the archives of the 1.2.x and 1.3.x forums.

Re: need speed

Permanent link to this post Posted by steve » Fri Jul 21, 2017 3:58 pm

autodctr wrote:I want to at least get a feel for what I am doing before hauling it out to church and swapping out the other machine.

Very wise ;)

autodctr wrote:I started Jack

How did you do that?
I usually use "QjackCtl" (Jack Audio Connection Kit) for configuring, starting and stopping Jack.
If your system is going to always be used with Jack, then it will probably be more convenient to configure the system to start Jack on log-in, but QjackCtl is very convenient for testing the set-up and getting everything working.

autodctr wrote:I opened Jack

Not sure what you mean. "Jack" is a service, not an application. Jack itself does not have a graphical interface.

If Audacity shows "Jack" in Preferences, then Jack is running.
Ensure that Jack is selected as the "host" in the device toolbar. Normally you would want the recording and playback devices set to "System". Then try playing something. If it plays with those settings, then it's working.
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 44666
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: need speed

Permanent link to this post Posted by autodctr » Fri Jul 21, 2017 4:12 pm

I started Audacity and selected Jack on everything I could find under Preferences. However, Audacity is showing a high level of sound output, but there is no sound from the speakers. What did I screw up?
autodctr
 
Posts: 50
Joined: Sun Jun 19, 2016 2:01 pm
Operating System: Linux *buntu

Re: need speed

Permanent link to this post Posted by autodctr » Fri Jul 21, 2017 4:15 pm

OK: got sound now. In the window that opens when I click on the Jack icon, do I have to do anything in that window before opening Audacity?
autodctr
 
Posts: 50
Joined: Sun Jun 19, 2016 2:01 pm
Operating System: Linux *buntu

Re: need speed

Permanent link to this post Posted by autodctr » Fri Jul 21, 2017 4:21 pm

Rebooted machine and Jack is not running. How do I make it run on start-up?
autodctr
 
Posts: 50
Joined: Sun Jun 19, 2016 2:01 pm
Operating System: Linux *buntu

Re: need speed

Permanent link to this post Posted by steve » Fri Jul 21, 2017 6:40 pm

autodctr wrote:How do I make it run on start-up?

The hard bit first: Work out what command line options you need to start Jack.

Try
Code: Select all
jackd -r -d alsa -r 44100

If that fails, try:
Code: Select all
jackd -r -d alsa -r 44100 -P

If that fails, check the Jack manual:
Code: Select all
man jackd

and / or Jack help:
Code: Select all
jackd --help

and / or
Code: Select all
Google.com
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 44666
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: need speed

Permanent link to this post Posted by steve » Fri Jul 21, 2017 6:42 pm

Once you have Jack starting reliably from the command line, add that command to your start-up items (on my system it's called "Session and Startup")
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 44666
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: need speed

Permanent link to this post Posted by autodctr » Wed Jul 26, 2017 3:53 pm

Alright. I didn't bother trying to get Jack to run on boot. Instead, I made a picture to use as wallpaper that says in big letters: Start JACK. (Much easier. :-) )

I tried recording 2 channels and it worked just fine. I am going to try later to output via USB cable from one computer to another. If I can get that to work, I have several 18 channel recordings that I can try.

Got a question though. You said to make sure everything runs the same sampling rate. I know where to choose that in Audacity, but I don't know where that is in Jack. Also, what sampling rate should I be using?
autodctr
 
Posts: 50
Joined: Sun Jun 19, 2016 2:01 pm
Operating System: Linux *buntu

Re: need speed

Permanent link to this post Posted by steve » Wed Jul 26, 2017 4:23 pm

autodctr wrote: I didn't bother trying to get Jack to run on boot. Instead, I made a picture to use as wallpaper that says in big letters: Start JACK.

:D
If that works for you, then why not!

If you use QjackCtl to start Jack, the sample rate settings are in the "Setup" dialog (click the Setup button).

The most "standard" sampling rate is 44100 Hz. That's what audio CDs use and it's the default in Audacity. It's probably the default for Jack.
44100 is a good choice unless you have a specific reason to use something else (for example, I know of one USB mic that frequently has problems unless running at 48000 Hz, but that's unusual).
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 44666
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: need speed

Permanent link to this post Posted by autodctr » Sun Jul 30, 2017 3:51 pm

Again, there is no joy. It is still doing the exact same thing with Jack handling everything. About every 2 minutes, a buzzing noise fades in on all 18 channels, lasts about 20 seconds and then fades out. 2 minutes later, same thing.
autodctr
 
Posts: 50
Joined: Sun Jun 19, 2016 2:01 pm
Operating System: Linux *buntu

Re: need speed

Permanent link to this post Posted by steve » Sun Jul 30, 2017 4:21 pm

Is the buzzing accompanied by a huge number of xruns reported in QJackCtl?
Did you ever tell us what the device is that you are recording with?
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 44666
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

PreviousNext

Return to GNU/Linux and Unix-like



Who is online

Users browsing this forum: No registered users and 2 guests