Audacity won't start (Ubuntu 16.10) error

Help for Audacity 2.x.x on GNU/Linux.

ImageThis forum is for Audacity 2.x.x on GNU/Linux and Unix-like operating systems.
Please state which version of Linux you are using, the exact three-section version number of Audacity from Help > About Audacity... and whether you installed your distribution's release or daily version of Audacity or compiled Audacity from source code.

Audacity 1.2.x and 1.3.x are obsolete and no longer supported. If you still have those versions, please upgrade at http://www.audacityteam.org/download/.
The old forums for those versions are now closed, but you can still read the archives of the 1.2.x and 1.3.x forums.

Audacity won't start (Ubuntu 16.10) error

Permanent link to this post Posted by sirdude » Fri Apr 14, 2017 3:56 pm

Hi all,

This is my first post here, I really hope that you can help! I have ducked and googled, but could not find a solution to the problem I'm experiencing. I am not a super technical linux user, has to be said as well.

I strongly suspect that since I updated from Ubuntu 16.04 LTS to 16.10 audacity won't start anymore. The icon flashes and then stops, and nothing happens. I tried uninstalling and reinstalling in the Software Centre, but no different result. Then I tried uninstalling, and then installing via the ubuntuhandbook PPA http://ubuntuhandbook.org/index.php/tag/audacity/. Still the same result. When I try starting it from a terminal typing:
Code: Select all
audacity

and hitting enter it gives as only output:
Code: Select all
audacity: symbol lookup error: audacity: undefined symbol: PaAlsa_GetStreamInputCard


I don't know what it means. If you do, and could walk me through a solution, please enlighten me! :) And perhaps more people using Ubuntu 16.10 are struggling..

Cheers, sirdude
Last edited by Gale Andrews on Fri Apr 14, 2017 5:30 pm, edited 1 time in total.
Reason: removed expletive
sirdude
 
Posts: 2
Joined: Fri Apr 14, 2017 3:42 pm
Operating System: Linux *buntu

Re: Audacity won't start (Ubuntu 16.10) error

Permanent link to this post Posted by Gale Andrews » Fri Apr 14, 2017 5:50 pm

Have you self-compiled PortAudio or some application that uses it, or installed a new audio application since installing 16.10?

What does this return?
Code: Select all
ldd /usr/bin/audacity | grep portaudio

If it returns /usr/lib/ then I would report it to Ubuntu because it looks like a system problem.

Also if you updated to Ubuntu 16.10 over 16.04 this could be the reason. This isn't a reliable way of updating. Try installing 16.10 fresh.


Gale
________________________________________FOR INSTANT HELP: (Click on Link below)
* * * * * Tips * * * * * Tutorials * * * * * Quick Start Guide * * * * * Audacity Manual
Gale Andrews
Quality Assurance
 
Posts: 25545
Joined: Fri Jul 27, 2007 12:02 am
Operating System: Windows 10

Re: Audacity won't start (Ubuntu 16.10) error

Permanent link to this post Posted by sirdude » Mon Apr 17, 2017 11:35 am

Hi Gale,

Thanks for your reply! I updated the system to 17.04 a few days ago, and the error is still the same. I did install OpenFrameworks and Android libraries, but not sure if that was the reason it doesn't work. I just tried your suggested input, and got:
Code: Select all
libportaudio.so.2 => /usr/local/lib/libportaudio.so.2 (0x00007fd875d3f000)

Going from this, what would you say I should do?

Best,
Wouter
sirdude
 
Posts: 2
Joined: Fri Apr 14, 2017 3:42 pm
Operating System: Linux *buntu

Re: Audacity won't start (Ubuntu 16.10) error

Permanent link to this post Posted by Gale Andrews » Mon Apr 17, 2017 12:09 pm

An Audacity package installation in /usr/ should not be pointing to portaudio in usr/local/lib. That local portaudio seems to be the problem.

I assume you could mess up your optional applications if you interfere with the local portaudio, so try launching Audacity from the terminal thus:
Code: Select all
LD_LIBRARY_PATH=/usr/lib/x86_64-linux-gnu/ audacity

If that works you can adjust the "Exec" line in your Audacity.desktop file (presumably in /usr/share/applications/ ) with that line so that you don't need to use the Terminal to launch Audacity.


Gale

sirdude wrote:Hi Gale,

Thanks for your reply! I updated the system to 17.04 a few days ago, and the error is still the same. I did install OpenFrameworks and Android libraries, but not sure if that was the reason it doesn't work. I just tried your suggested input, and got:
Code: Select all
libportaudio.so.2 => /usr/local/lib/libportaudio.so.2 (0x00007fd875d3f000)

Going from this, what would you say I should do?

Best,
Wouter
________________________________________FOR INSTANT HELP: (Click on Link below)
* * * * * Tips * * * * * Tutorials * * * * * Quick Start Guide * * * * * Audacity Manual
Gale Andrews
Quality Assurance
 
Posts: 25545
Joined: Fri Jul 27, 2007 12:02 am
Operating System: Windows 10


Return to GNU/Linux and Unix-like



Who is online

Users browsing this forum: No registered users and 2 guests